struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chamara Gunaratne" <chamara.gunara...@focusinc.com>
Subject Using token-session with IE
Date Tue, 18 Mar 2008 17:55:44 GMT
Hi,
I have a rather strange problem. I am using token-session interceptor to
deal with the multiple requests problem. The relevant part of the struts.xml
file is appended below. 

This works fine in Firefox (2 and 3 beta) but fails in IE7. When the form
(which contains the s:token tag) submit button is clicked rapidly several
times, a blank screen is displayed and the URL shown is the URL of the
action. This is probably something to do with IE, and I would really
appreciate any advice on how to solve this ... Thanks!

<-- struts.xml snip -->
<constant name="struts.devMode" value="true" />

<package name="lwbc3-default" namespace="/applications"
extends="struts-default">
   <action name="ApplicationSubmitAction.do"
class="test.action.ApplicationAction">
      <interceptor-ref name="defaultStack"/>
      <interceptor-ref name="token-session"/>
      <result name="success" type="redirect">thanks.html</result>
      <result name="input">/applications/application.jsp</result>
      <result name="invalid.token">thanks.html</result>
   </action> 




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message