struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeromy Evans <jeromy.ev...@blueskyminds.com.au>
Subject Re: [S2] IE does not refresh page
Date Wed, 20 Feb 2008 05:41:14 GMT
Hmm...this is a guess, but there's a relevant issue in IE's innerHTML 
implementation.  Dojo uses this to insert the response into the page.  
This particular issue is that tables must be xhtml-compliant. 
Specifically, they must contain all the required tags including <thead> 
and <tbody>.  Try adding those tags to your response.  IE definitely 
does not permit you to insert (most) invalid HTML into the page.

If not successful, IE is hopeless at debugging this, so simplify the 
pages (the one making the request and the result) to isolate the cause.

Good luck!

PS.
All your calls like this:

<s:property value="getModuleName()"/>

can be replaced with this:

<s:property value="moduleName"/>

as it's a javabean-compliant property name (what have works too but is 
not the convention)

carmi_cd wrote:
> hi, yes my submit reached my action because the record is saved/updated in
> the database.
> yes the list is the response from the action. 
>
> the list is refreshing in Firefox but not in IE..here is part of list.jsp
>
>                         <s:iterator id="users" value="getUsersList()">
>                             <tr> 
>                                 <td align="left" valign="top">
>                                     <s:checkbox name="selectedGroup"
> fieldValue="%{getUserId()}%{nextCell.label}" 
>                                     theme="simple" />
>                                 </td>
>                                 <td align="left" valign="top">
>                                     <s:url id="list"
> value="UserMgt_input.action?userid=%{getUserId()}&task=edit"/>
>                                     <s:a theme="ajax" 
>                                          href="%{list}" 
>                                          targets="module"
>                                          errorText="Unable to load list.">
>                                         <s:property value="getLastName()"/>
> , <s:property value="getFirstName()"/> <s:property value="getMiddleName()"/>
>                                     </s:a>
>                                 </td>
>                                 <td align="left" valign="top">
>                                     <s:property value="getUserName()"/>
>                                 </td>
>                                 <td align="left" valign="top">
>                                     <s:iterator id="modules"
> value="getModules()">
>                                         <s:property
> value="getModuleName()"/> ,                                    
>                                     </s:iterator>
>                                 </td>
>                             </tr>
>                         </s:iterator>        
>
> i'm using Struts 2.0.5. The theme being use is ajax. I hope I've given you
> enough information, 
> if not, dont hesitate to ask, i'm really new in Struts, I need help. Thanks
> again.
>
>
> Jeromy Evans - Blue Sky Minds wrote:
>   
>>
>> Setting showLoadingText="false" itself shouldn't affect this.
>>
>> Is the submit reaching your action?
>> Is the list that's refreshed the response from the action? Or is the 
>> refresh via a topic? Or refresh by some other means?
>> Does your response contain any inline javascript? Or dojo widgets/ajax
>> tags?
>>
>> The only other thing that frequently doesn't work is including inline 
>> javascript in the responses and expecting theme to execute at a 
>> particular time.
>> Which version of struts are you using btw?
>>
>> regards,
>>  Jeromy Evans
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>> For additional commands, e-mail: user-help@struts.apache.org
>>
>>
>>
>>     
>
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message