struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Indresh Chadha <ind_gem...@hotmail.com>
Subject RE: Problem with web.xml and Struts 1.3
Date Fri, 14 Dec 2007 13:44:03 GMT

Even I'm facing the same issue.
The only difference in my problem is that I'm not using the struts jar but
the actual source code.
So the struts classes are getting compiled in the WEB-INF/classes folder.

When I start my server it gives me the same error.
The ActionServlet.java contains the following line which is giving error:
        InputStream input = 
getServletContext().getResourceAsStream("/WEB-INF/web.xml");
I believe since the class file of ActionServlet is now under
WEB-INF/classes/org/apache/struts/action, that is why the path
"/WEB-INF/web.xml" does not hold good.

Any help will be greatly apprciated.


David G Friedman wrote:
> 
> Would you like to include your struts-config.xml and web.xml so we can try
> to help?
> 
> -----Original Message-----
> From: Angel Navarro [mailto:angelna@gmail.com]
> Sent: Tuesday, August 22, 2006 6:14 AM
> To: user@struts.apache.org
> Subject: Problem with web.xml and Struts 1.3
> 
> 
> Hi,
> 
> I have a big problem with an struts 1.3 application.
> My configuration:
> 
> Weblogic 8.1 sp4
> Struts 1.3
> Fedora
> 
> And when deploy a web application (WAR) I have this problem:
> 
> [DEBUG 2006-08-22 10:51:44,291]
> org.apache.struts.action.ActionServlet:1720 Scanning
> web.xml for controller servlet mapping
> [DEBUG 2006-08-22 10:51:46,586]
> org.apache.struts.util.PropertyMessageResources :115
> getMessage(en_US,configWebXml)
> [DEBUG 2006-08-22 10:51:46,591]
> org.apache.struts.util.PropertyMessageResources :212 loadLocale(en_US)
> [DEBUG 2006-08-22 10:51:46,592]
> org.apache.struts.util.PropertyMessageResources :236   Loading resource
> 'org/apache/struts/action/ActionResources_en_US.properties'
> [DEBUG 2006-08-22 10:51:46,592]
> org.apache.struts.util.PropertyMessageResources :263   Loading resource
> completed
> [DEBUG 2006-08-22 10:51:46,593]
> org.apache.struts.util.PropertyMessageResources :212 loadLocale(en)
> [DEBUG 2006-08-22 10:51:46,593]
> org.apache.struts.util.PropertyMessageResources :236   Loading resource
> 'org/apache/struts/action/ActionResources_en.properties'
> [DEBUG 2006-08-22 10:51:46,593]
> org.apache.struts.util.PropertyMessageResources :263   Loading resource
> completed
> [DEBUG 2006-08-22 10:51:46,594]
> org.apache.struts.util.PropertyMessageResources :212 loadLocale()
> [DEBUG 2006-08-22 10:51:46,594]
> org.apache.struts.util.PropertyMessageResources :236   Loading resource
> 'org/apache/struts/action/ActionResources.properties'
> [DEBUG 2006-08-22 10:51:46,595]
> org.apache.struts.util.PropertyMessageResources :263   Loading resource
> completed
> [DEBUG 2006-08-22 10:51:46,595]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.initProcessor
> [DEBUG 2006-08-22 10:51:46,595]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.configWebXml
> [DEBUG 2006-08-22 10:51:46,596]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.configMissing
> [DEBUG 2006-08-22 10:51:46,596]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.verifyForwardConfig.invalid
> [DEBUG 2006-08-22 10:51:46,596]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.unhandledException
> [DEBUG 2006-08-22 10:51:46,597]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.verifyPlugInConfigs.missing
> [DEBUG 2006-08-22 10:51:46,597]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.processInvalid
> [DEBUG 2006-08-22 10:51:46,597]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.notAuthorized
> [DEBUG 2006-08-22 10:51:46,597]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.verifyMessageResourcesConfigs.missing
> [DEBUG 2006-08-22 10:51:46,598]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.verifyMessageResourcesConfigs.key
> [DEBUG 2006-08-22 10:51:46,598]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.noInput
> [DEBUG 2006-08-22 10:51:46,598]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.configIO
> [DEBUG 2006-08-22 10:51:46,599]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.reloading
> [DEBUG 2006-08-22 10:51:46,599]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.processPath
> [DEBUG 2006-08-22 10:51:46,599]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.configInit
> [DEBUG 2006-08-22 10:51:46,599]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.configVerifying
> [DEBUG 2006-08-22 10:51:46,600]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.configExtends
> [DEBUG 2006-08-22 10:51:46,600]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.configFieldRequired
> [DEBUG 2006-08-22 10:51:46,600]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.sessionCreate
> [DEBUG 2006-08-22 10:51:46,601]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.verifyForwardConfig.missing
> [DEBUG 2006-08-22 10:51:46,601]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.configExtends.creation
> [DEBUG 2006-08-22 10:51:46,601]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.configCompleted
> [DEBUG 2006-08-22 10:51:46,601]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.verifyActionMappingClass.invalid
> [DEBUG 2006-08-22 10:51:46,602]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.configMapping
> [DEBUG 2006-08-22 10:51:46,602]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.requestDispatcher
> [DEBUG 2006-08-22 10:51:46,602]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.configParse
> [DEBUG 2006-08-22 10:51:46,603]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.finalizing
> [DEBUG 2006-08-22 10:51:46,603]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.formBean
> [DEBUG 2006-08-22 10:51:46,603]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.verifyActionMappingClass.missing
> [DEBUG 2006-08-22 10:51:46,603]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.verifyPlugInConfigs.invalid
> [DEBUG 2006-08-22 10:51:46,604]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.applicationLoading
> [DEBUG 2006-08-22 10:51:46,604]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.mappingType
> [DEBUG 2006-08-22 10:51:46,604]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.actionCreate
> [DEBUG 2006-08-22 10:51:46,605]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.applicationResources
> [DEBUG 2006-08-22 10:51:46,605]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.configFatal
> [DEBUG 2006-08-22 10:51:46,605]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.forwardPathNull
> [DEBUG 2006-08-22 10:51:46,605]
> org.apache.struts.util.PropertyMessageResources :278   Saving message key
> '.verifyMessageResourcesConfigs.invalid
> [ERROR 2006-08-22 10:51:46,607]
> org.apache.struts.action.ActionServlet:1727 The /WEB-INF/web.xml was
> not found.
> [ERROR 2006-08-22 10:51:46,608]  org.apache.struts.action.ActionServlet
> :397
> Unable to initialize Struts ActionServlet due to an unexpected exception
> or
> error thrown, so marking the servlet as unavailable.  Most likely, this is
> due to an incorrect or missing library dependency.
> javax.servlet.ServletException: The /WEB-INF/web.xml was not found.
>         at org.apache.struts.action.ActionServlet.initServlet()V(
> ActionServlet.java:1728)
>         at
> org.apache.struts.action.ActionServlet.init()V(ActionServlet.java
> :348)
>         at javax.servlet.GenericServlet.init
> (Ljavax/servlet/ServletConfig;)V(GenericServlet.java:258)
>         at weblogic.servlet.internal.ServletStubImpl$ServletInitAction.run
> ()Ljava/lang/Object;(ServletStubImpl.java:1094)
> 
> 60,1-8         6%
> 
> but WEB-INF/web.xml EXISTS.... and the path WEB-INF/web,xml is correct!!!!
> ,
> and WEB-INF are un capital letters.....I don't know?¿?¿?
> 
> Thanks
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Problem-with-web.xml-and-Struts-1.3-tp5922721p14336079.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message