struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Gordon <adam.gor...@readytalk.com>
Subject Re: Configuring Struts to use UTF-8 character encoding
Date Fri, 30 Nov 2007 15:47:07 GMT
I didn't know that page existed though it's essentially what I wound up doing.  My only concern
now is that it affects our entire webapp and while QA was going to do a full regression anyway,
I'm wondering what potential problems are now lurking in the deep, dark corners of our web
forms...

Thanks for the link.

--adam

Ted Husted wrote:

> On Nov 28, 2007 10:53 AM, Adam Gordon <adam.gordon@readytalk.com> wrote:
>   
>> What about the use of a filter to set the character encoding?  Is this
>> the only way to go for Struts?
>>     
>
> I'd say so. It might be possible to add something to the
> ActionServlet, but the solution wouldn't be any less "heavy handed"
> than using a filter. This sort of thing is why filters were invented
> :)
>
> There's a page on the Tomcat wiki that talks about setting up a UTF
> filter, if you haven't seen it.
>
>  * http://wiki.apache.org/tomcat/Tomcat/UTF-8
>
> -Ted.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message