struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Relph" <relp...@gmail.com>
Subject struts2 portlet support
Date Thu, 01 Nov 2007 18:20:56 GMT
I was hoping to get help deploying a struts2 portlet.  I have been
developing based on the portlet archetype with the embedded jetty/pluto
portlet container as detailed at http://portletwork.blogspot.com/

This archetype is based on struts 2.1.0, and developing with it has been
great.  However, when deploying to a WAS 6.1 server, i would get "Error 404:
There is no Action mapped for action name HealtheAdmin/",  "HealtheAdmin"
being the name of my portlet.  While trying to solve this problem, I
downloaded the same archetype with struts 2.0.9 dependencies/config, and it
deployed on my server no problem.  So basically, I have been developing with
struts 2.1.0 b/c of how easy the embedded portlet container makes it, and
then deploying with 2.0.9.

However, I would like to not have the mis-matched versions.  I was hoping
someone could help clarify the changes i need to make for my 2.1.0 portlet
to work so that i can get stop deploying with 2.0.9.  I have also looked at
the 2.1.1 portlet sample application, and tried deploying it.  I built it
with no profiles, but got the same error as before ("Error 404: There is no
Action mapped for action name HealtheAdmin/").  If i build it with the
"pluto" profile, I get several errors - first, the pluto plugin seems to
generate a web.xml that does not match the dtd, so it is invalid.  If i fix
that manually, my server complains about having matching servlet and portlet
names.

Can anyone explain the differences between 2.0.9, 2.1.0, and 2.1.1 portlet
applications, how to build them, and where configuration unique to my
portlet & server should be?

Thanks,
Brian

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message