struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gilday" <martin.li...@imap.cc>
Subject Re: Unnecessary onsubmit
Date Tue, 27 Nov 2007 16:29:11 GMT
I've not used a validation attribute.  An example:
<@s.form namespace="/" action="registration!save" method="post">

The stack just has the standard interceptor ref <interceptor-ref
name="validation">
Is this an old issue, I get the same alert in JIRA all the time
(WebWork?)

----- Original message -----
From: "Dave Newton" <newton.dave@yahoo.com>
To: "Struts Users Mailing List" <user@struts.apache.org>
Date: Tue, 27 Nov 2007 08:16:42 -0800 (PST)
Subject: Re: Unnecessary onsubmit

With the regular <s:form...> tag without the
"validation" attribute set?!

d.

--- Martin Gilday <martin.lists@imap.cc> wrote:

> We are using the validaiton interceptor but not
> client side javascript
> validation.  However we are still seeing lots of
> onsubmit="customOnsubmit_registration(); return
> true;" appearing in the
> views.  On form submission you get a js error as the
> function does not
> exist.  Why is this appearing and is there a simple
> way to prevent it?
> 
> Thanks,
> Martin.
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> user-unsubscribe@struts.apache.org
> For additional commands, e-mail:
> user-help@struts.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message