struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Newton <newton.d...@yahoo.com>
Subject Re: Struts Application is not running
Date Tue, 02 Oct 2007 19:30:00 GMT
I'd turn up the logging level. My initial suspicion
would be a configuration error, but it's kind of hard
to say at the moment.

--- aum strut <aum.struts@gmail.com> wrote:

> hi all,
> 
> i have developeda small application in struts.but
> itis not
> running.andtomcat log file is giving the error that
> it is unable to
> find ActionServlet
> calss.
> i have configured ActionServlet class in web.xml as
> 
> <servlet>
>     <servlet-name>action</servlet-name>
>    
>
<servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
>     <init-param>
>       <param-name>config</param-name>
>      
>
<param-value>/WEB-INF/struts-config.xml</param-value>
>     </init-param>
>     <init-param>
>       <param-name>debug</param-name>
>       <param-value>3</param-value>
>     </init-param>
>     <init-param>
>       <param-name>detail</param-name>
>       <param-value>3</param-value>
>     </init-param>
>     <load-on-startup>0</load-on-startup>
>   </servlet>
>   <servlet-mapping>
>     <servlet-name>action</servlet-name>
>     <url-pattern>*.do</url-pattern>
>   </servlet-mapping>
>   <welcome-file-list>
>     <welcome-file>index.jsp</welcome-file>
>   </welcome-file-list>
> 
> Please suggest wat can be the cause of the error.
> 
> Regards,
> Umesh
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message