struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cesar Arevalo <cesararev...@yahoo.com>
Subject Re: [ActionServlet] /WEB-INF/web.xml was not found
Date Thu, 04 Oct 2007 23:26:36 GMT
Hey, what version of the jboss-web.dtd are you using, see here for the types:

http://www.jboss.org/j2ee/dtd/

I see that the context-root element is not in the http://www.jboss.org/j2ee/dtd/jboss-web.dtd,
it is until http://www.jboss.org/j2ee/dtd/jboss-web_3_0.dtd that this element is present.

HTH
-Cesar

----- Original Message ----
From: "ROWLAND, CLAY, ATTSI" <clayrowland@att.com>
To: user@struts.apache.org
Sent: Thursday, October 4, 2007 3:37:48 PM
Subject: [ActionServlet] /WEB-INF/web.xml was not found

hi.   i'm trying to deploy my first struts 1.3.8 web app on jboss-4.2.1
on windows and am getting an exception when i deploy my .war file.
 
18:15:43,744 ERROR [ActionServlet] The /WEB-INF/web.xml was not found.
(please let me know if you'd like to see the full exception text)

however, web.xml exists inside my .war file in the WEB-INF dir (and as
ActionServlet is only init'ed because it exists in the web.xml, i'm
dumbfounded).  the struts .jar files are in the WEB-INF/lib directory
within the .war.  here are my config files, all of which are in the
WEB-INF dir:
 
web.xml

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE web-app
  PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN"
  "http://java.sun.com/j2ee/dtds/web-app_2_2.dtd";>

<web-app>

  <!--  Action Servlet Configuration -->
  <servlet>
   <servlet-name>action</servlet-name>
 
<servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
    <init-param>
      <param-name>config</param-name>
      <param-value>/WEB-INF/struts-config.xml</param-value>
    </init-param>
    <load-on-startup>2</load-on-startup>
  </servlet>

  <!-- Action Servlet Mapping -->

 <servlet-mapping>
    <servlet-name>action</servlet-name>
    <url-pattern>*.do</url-pattern>
  </servlet-mapping>


  <!-- Struts Tag Library Descriptors -->
  <taglib>
    <taglib-uri>/WEB-INF/struts-bean.tld</taglib-uri>
    <taglib-location>/WEB-INF/struts-bean.tld</taglib-location>
  </taglib>

  <taglib>
    <taglib-uri>/WEB-INF/struts-html.tld</taglib-uri>
    <taglib-location>/WEB-INF/struts-html.tld</taglib-location>
  </taglib>

  <taglib>
    <taglib-uri>/WEB-INF/struts-logic.tld</taglib-uri>
    <taglib-location>/WEB-INF/struts-logic.tld</taglib-location>
  </taglib>

</web-app>

struts-config.xml

<?xml version="1.0" encoding="ISO-8859-1" ?>
<!DOCTYPE struts-config PUBLIC "-//Apache Software Foundation//DTD
Struts Configuration 1.0//EN"
"http://jakarta.apache.org/struts/dtds/struts-config_1_0.dtd";>
<struts-config>
  <form-beans>
    <form-bean name="ticketForm"
type="com.att.devtools.ticket.TicketForm"/>
  </form-beans>
  <action-mappings>
    <action    path="/ticketaction"
               type="com.att.devtools.ticket.TicketAction"
               name="ticketForm">
      <forward name="success" path="/ticketInfo.jsp"/>
      <forward name="success" path="/failure.html"/>
    </action>
  </action-mappings>
</struts-config>

jboss-web.xml

<?xml version="1.0" encoding="UTF-8"?>
<jboss-web>
    <context-root>Ticket</context-root>
</jboss-web>


i feel like i'm missing a simple configuration detail.   if anyone has
encountered this issue before, i'd love to hear how you resolved it.

thanks.




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org





---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message