struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Viplav Kallepu" <viplav.kall...@gmail.com>
Subject Re: Struts debug mode
Date Thu, 04 Oct 2007 16:23:27 GMT
Thanks for the replies. I haven't tried jadeclipse and eclipse europa. I
will try them to and see how debug mode works. One thing I wansn't able to
figure out. why do we need source files of third party jars. Even the java
jre we include is like third party to eclipse. Still it is able to debug the
core java application. I am trying to understand if my understanding is
wrong please excuse me. If I keep a breakpoint in action class it should
stop there and show me the values that was what I was expecting with my past
experience using eclipse.

On 10/3/07, Stephen Boudreaux <smartr@gmail.com> wrote:
>
> I've found that Eclipse can be confusing when you want to attach the
> source of a library. Namely, you can't right click a library and
> select properties when in the J2EE view. You can go to the Java view
> and go there to attach the source there. If you are still having
> mysterious issues, you might want to consider jumping onto Eclipse
> Europa (3.3) WTP (I think they made it alot easier to get set up), or
> alternatively use the Red Hat Developer Studio (which is Eclipse 3.3
> plus WTP plus several other plugins).
>
> On 10/3/07, João Vieira da Luz <joao.luz@gmail.com> wrote:
> > in order to go third party classes you must have source attached those
> third
> > party jars or you could use jad plugin (
> http://jadclipse.sourceforge.net/).
> >
> >
> >
> > On 10/2/07, Viplav Kallepu <viplav.kallepu@gmail.com> wrote:
> > >
> > > Thanks for the reply.. when I put breakpoints in my action class and
> start
> > > the server in debugging mode and run my application in browser.. its
> > > stopping at the breakpoint and not going forward(It is showing it in
> the
> > > debug console)..I feel it is not able to find the source files as in
> > > .deployables donot contain source files.. Can anyone help me sorting
> out
> > > this..
> > >
> > > On 10/2/07, João Vieira da Luz <joao.luz@gmail.com> wrote:
> > > >
> > > > Remote debugging is the keyword. WTP already supports that.
> > > >
> > > > On 10/2/07, Viplav Kallepu <viplav.kallepu@gmail.com> wrote:
> > > > >
> > > > > Hi,
> > > > >
> > > > > I am using struts 1.3.8 with eclipse 3.1 (wtp) and tomcat 5.5
> .  Can
> > > > anyone
> > > > > please tell me how to enable debugging in it like we debug the
> core
> > > java
> > > > > application in eclipse. I googled it but the I wasn't able to find
> a
> > > > > single
> > > > > correct solution to try (I cant use myeclipse because I have to
> use
> > > > > eclipse
> > > > > in my work).
> > > > >
> > > > > --
> > > > > Regards
> > > > > Viplav Kallepu
> > > > >
> > > >
> > >
> > >
> > >
> > > --
> > > Regards
> > > Viplav Kallepu
> > >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>


-- 
Regards
Viplav Kallepu

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message