struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Newton <newton.d...@yahoo.com>
Subject Re: Struts anchor question
Date Wed, 12 Sep 2007 14:44:47 GMT
http://struts.apache.org/2.x/docs/url.html

--- TonyD <antonio.ditommaso@eunics.it> wrote:

> 
> Because the HTML anchor <a.../> tag with a URL
> created via <s:url.../> replaces the "&" character
> between parameters with
> "amp;" characters
> and my link doesn't work.
> 
> 
> 
> newton.dave wrote:
> > 
> > --- TonyD <antonio.ditommaso@eunics.it> wrote:
> >> How to obtain the equivalent html anchor in
> struts? 
> >> 
> >> <.a href=<s:property value="%{url}"/>
> >> target="_blank">     
> >>    ... 
> >> <./a>
> >> 
> >> I tried with the "targets" parameter but it
> doesn't
> >> work. 
> >> 
> >> <s:a href="%{url}" targets="_blank">     
> >>    ... 
> >> </s:a> 
> > 
> > Why not just use an HTML <a.../> tag with a URL
> > created via <s:url.../>?
> > 
> > d.
> > 
> > 
> >
>
---------------------------------------------------------------------
> > To unsubscribe, e-mail:
> user-unsubscribe@struts.apache.org
> > For additional commands, e-mail:
> user-help@struts.apache.org
> > 
> > 
> > 
> 
> -- 
> View this message in context:
>
http://www.nabble.com/Struts-anchor-question-tf4428839.html#a12636331
> Sent from the Struts - User mailing list archive at
> Nabble.com.
> 
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> user-unsubscribe@struts.apache.org
> For additional commands, e-mail:
> user-help@struts.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message