struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kun Niu" <haoniu...@gmail.com>
Subject Re: Problem about the hello world struts2 example.
Date Sun, 26 Aug 2007 05:46:44 GMT
Thank you for your reply.
I saw the following error message when my tomcat startup:
WARN com.opensymphony.xwork2.config.providers.InterceptorBuilder
Unable to load config class
org.apache.struts2.jsf.FacesSetupInterceptor at interceptor -
jar:file:/home/niu/workspace3.3/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/brewmusicblog/WEB-INF/lib/struts2-jsf-plugin-2.0.9.jar!/struts-plugin.xml:14:97
probably due to a missing jar, which might be fine if you never plan
to use the jsfSetup interceptor
ERROR com.opensymphony.xwork2.config.providers.InterceptorBuilder
Actual exception

Caught Exception while registering Interceptor class
org.apache.struts2.jsf.FacesSetupInterceptor - interceptor -
jar:file:/home/niu/workspace3.3/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/brewmusicblog/WEB-INF/lib/struts2-jsf-plugin-2.0.9.jar!/struts-plugin.xml:14:97

Caused by: java.lang.NullPointerException
	at org.apache.struts2.jsf.FacesSetupInterceptor.init(FacesSetupInterceptor.java:146)

org.xml.sax.SAXParseException: src-import.0: Failed to read imported
schema document 'null'.
	at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:232)

And I've got the following line in my web.xml:
  	<taglib>
  		<taglib-uri>/struts-tags</taglib-uri>
  		<taglib-location>/WEB-INF/tld/struts-tags.tld</taglib-location>
  	</taglib>
I wonder if it's the spring object factory caused the problem.
I copied all the configuration files from the portlet sample bundled
with struts2 and made some change.
Thanks again for your kind reply.

Regards.

2007/8/26, Nuwan Chandrasoma <mymailnot@gmail.com>:
> Hi,
>
> This can be due to many reasons, do you see any error messages in the
> console of the app server?, just a guess, have you included the
> struts-tag declaration in you jsp?
>
> Thanks,
>
> Nuwan
>
>
> Kun Niu wrote:
> > Dear all,
> > I wonder if anyone has ever met the problem like me.
> > Now I've come to  the first step.
> > I create the view jsp file and the action bean following the guide.
> > And I configured struts.xml file.
> > I can see the page come out on my browser.
> > But I can only see the title.
> > I can't file the message "Struts is up and running ...".
> > I wonder if anyone can help solve the problem.
> > Just show the message by using s:property.
> > Any help would be appreciated and thanks in advance.
> >
> > Regards
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> > For additional commands, e-mail: user-help@struts.apache.org
> >
> >
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>


-- 
失业
         牛坤
MSN:haoniukun@hotmail.com
Mime
View raw message