struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Mammen <John_Mam...@infosys.com>
Subject RE: X11 server at :0.0
Date Mon, 06 Aug 2007 14:56:27 GMT
Hi Guys,

  From your explanation, I understand that the X11 server is required to render graphics.
Thank you guys for the information.

 But I don't understand why websphere throws this error when I am deploying an EAR with external
Jars imported directly into my EAR, but deploys the application successfully the moment these
JARs are removed?

 Also why does this error come at the time of deployment? Isn't this more of a runtime issue
?

 If I ever get a chance to meet the guys at IBM, an ass whoppin' would be the least I could
offer them for them for their 'WONDERFUL' documentation. I've been struggling with this issue
day and night for 6 days straight now.

John.

-----Original Message-----
From: Roberto Nunnari [mailto:roberto.nunnari@supsi.ch]
Sent: Monday, August 06, 2007 7:53 PM
To: Struts Users Mailing List
Subject: Re: X11 server at :0.0

Hi John.

First of all try to run your appserver with the java command line
option: -Djava.awt.headless=true

if that is not enough, then make sure the required X libraries are
installed and in the appserver LD_LIBRARY_PATH.



Al Sutton wrote:
> Yup, it's a problem where the full set of required X11 libraries aren't
> installed on the machine your trying to run the webapp on and you're doing
> something involving graphics (e.g. drawing to a buffer and serving the image
> from a servlet).

right.


>
> Best bet is to install the X libraries, next best would be to use the
> command line switch which removes the need for the X11 libs
> (-Djava.awt.headless=true )

it is not exactly so.. -Djava.awt.headless=true lets you run your
app that uses the X11 libs even if X is not installed on your server
(ie, the server only has alpha-numeric and no XWindow),
but you still need the required X11 libs.


>
> Al.
>
> -----Original Message-----
> From: John Mammen [mailto:John_Mammen@infosys.com]
> Sent: 06 August 2007 12:18
> To: 'user@struts.apache.org'
> Subject: X11 server at :0.0
>
>
>
> Hi,
>
> Have any of you faced this issue while deploying an application in WAS?
>
>
> Error executing deployment: java.lang.InternalError. Error is Can't connect
> to X11 window server using ':0.0' as the value of the DISPLAY variable..
>
> java.lang.InternalError: Can't connect to X11 window server using ':0.0' as
> the value of the DISPLAY variable. I found this document on the IBM site
> which says make an entry in Server>Application Servers> <Application server>
>> Java and Process management> Process definition > Custom properties
>
> Enter 'DISPLAY' in the name field (which I did) and #port number in value
> field (I entered 6000). But I still get the same error.
>
> Regards,
> John.
>
>
> **************** CAUTION - Disclaimer *****************
> This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely
> for the use of the addressee(s). If you are not the intended recipient,
> please notify the sender by e-mail and delete the original message. Further,
> you are not to copy, disclose, or distribute this e-mail or its contents to
> any other person and any such actions are unlawful. This e-mail may contain
> viruses. Infosys has taken every reasonable precaution to minimize this
> risk, but is not liable for any damage you may sustain as a result of any
> virus in this e-mail. You should carry out your own virus checks before
> opening the e-mail or attachment. Infosys reserves the right to monitor and
> review the content of all messages sent to or from this e-mail address.
> Messages sent to or from this e-mail address may be stored on the Infosys
> e-mail system.
> ***INFOSYS******** End of Disclaimer ********INFOSYS***
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message