struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gainty" <mgai...@hotmail.com>
Subject Re: How can one servlet (ActionServlet) effect another servlet (AxisServlet)...?
Date Wed, 06 Jun 2007 14:06:23 GMT
Jeff-

Apparently JBoss' CATALINA container is hardbound to that port and the only 
solution is to redirect to another port within jboss-service.xml
in tomcat-5.5.sar

No, actually you can't. To be specific, there is a service called something 
like tomcat-5.5.sar. This SAR (Service ARchive) contains the Catalina engine 
from Tomcat 5.5, but not the actual Tomcat server itself. JBoss effectively 
does the same thing as Tomcat when executing code in the Web Container, 
because it's just calling the Catalina functions. It can't stand alone 
though, because the bootstrap code is missing, and you can't simply point 
JBoss at a different Tomcat installation because a SAR is a slightly 
different representation of the same code. You can, however, take the WAR 
from an existing Tomcat installation and hot-deploy it to JBoss provided 
there's no version issues.

To address the OP, you would have to change the port number that JBoss uses 
for the Web Container by editing the jboss-service.xml file in the 
tomcat-5.5.sar directory.

HTH
Martin--
This email message and any files transmitted with it contain confidential
information intended only for the person(s) to whom this email message is
addressed.  If you have received this email message in error, please notify
the sender immediately by telephone or email and destroy the original
message without making a copy.  Thank you.

----- Original Message ----- 
From: "Jeff Amiel" <jeff.amiel@gmail.com>
To: "Struts Users Mailing List" <user@struts.apache.org>
Sent: Wednesday, June 06, 2007 9:20 AM
Subject: Re: How can one servlet (ActionServlet) effect another servlet 
(AxisServlet)...?


> On 6/6/07, Niall Pemberton <niall.pemberton@gmail.com> wrote:
>> The latest Tomcat 5.5 release is 5.5.23 in March 2007. If you really
>> are running a very old version of Tomcat - then upgrading would be a
>> good idea anyway - whether it fixes this bug or not. First step though
>> is to work out what version you're running.
>
> Anyone know how to upgrade tomcat versions without upgrading the
> 'surrounding' jboss?
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message