struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nils-Helge Garli" <nil...@gmail.com>
Subject Re: Minimized Window State NOT working
Date Mon, 25 Jun 2007 06:56:24 GMT
Hi!

To quote the spec:

"When a portlet is in MINIMIZED window state, the portlet should only render
minimal output or no output at all."

As I interpret this, it's the responsibility of the portlet to display the
correct content. So you need to do some checking for the window state and
take according action in your portlet.

However, there wasn't much information about the minimized window state in
the spec. I couldn't find any description of the contract between the portal
server's "window buttons" and the window states, so there might be different
behaviour from server to server. Have you tried deploying to a different
container, for instance pluto?

Nils-H

On 6/25/07, tom tom <j_lalith@yahoo.com> wrote:
>
> Hi,
>
> In Struts2 portlets development, It looks to us that
> the minimize does not work as expected, When we presss
> the minimize button instead of minimizing it shows the
> same content.
>
> to my understanding it should not render anything at
> all.
>
> We trying this on uPortal.
>
> Can some one else try these things.
>
> Is there any workaround.
>
> Thanks,
>
>
>
>
> ____________________________________________________________________________________
> 8:00? 8:25? 8:40? Find a flick in no time
> with the Yahoo! Search movie showtime shortcut.
> http://tools.search.yahoo.com/shortcuts/#news
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message