struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antony Stubbs <antony.stu...@gmail.com>
Subject Re: [S2] Websphere 6.1 Showcase application, Response already committed warning in logs
Date Tue, 03 Apr 2007 06:17:49 GMT

Just double checked your fix, still doesn't work for me.

I will let you know how it goes after I finish installing the fix packs.


Antony Stubbs wrote:
> 
> Yes I have tried your solution, and I still get those messages, along with
> the lines appended to my js files.
> 
> I'm trying to patch WebSphere now, but am not sure if the fix described
> here is available.
> You see I think it may be caused by 
> http://www-1.ibm.com/support/docview.wss?uid=swg24014758 this WebSphere
> issue .
> Found while browsing 
> http://www.mail-archive.com/dev@myfaces.apache.org/msg17765.html this
> thread .
> 
> I will double check your fix again in a second - download of fix pack to
> 6.0.5 is going to take an hour. then there's a interim fix for the issue i
> linked to (but gotta install the .5 fix pack first).
> 
> 
> Tapio Holopainen wrote:
>> 
>> If you define WebsphereFilterDispatcher in your web.xml, do you still get  
>> those 'response already committed' -messages?
>> 
>> I'm using 2.0.6 release and managed to get rid of those messages by  
>> defining the filterdispatcher.
>> 
>> But the AJAX problem is still not solved. I'm hoping that someone in  
>> Struts2 team would start to investigate this issue...
>> 
>> - Tapio
>> 
>> 
>> On Tue, 03 Apr 2007 06:19:36 +0300, Antony Stubbs  
>> <antony.stubbs@gmail.com> wrote:
>> 
>>>
>>> FYI - the same thing is occuring the the struts-blank.war application.  
>>> (i.e.
>>> the Cannot set status / header. Response already committed messages.)
>>>
>>> I have even downloaded the 2.0.7 release and tried using that - no
>>> difference.
>>>
>>>
>>> Antony Stubbs wrote:
>>>>
>>>> Looks like I've hit the same
>>>> http://www.nabble.com/Config-Browser-half-works---java.io.FileNotFoundException-tf3503552.html#a9785373
>>>> problem .
>>>> Any news? The fix you posted to doesn't work, however it does make the
>>>> errors show faster.
>>>> It breaks my dojo js, because WebSphere appends the error
>>>> message:"Error
>>>> 404: SRVE0190E: File not found: /struts/simple/dojoRequire.js" onto the
>>>> bottom of the js files.
>>>> E.g.
>>>> dojo.hostenv.writeIncludes(); // not needed, but allows the Venkman
>>>> debugger to work with the includes
>>>> 2
>>>> 3Error 404: SRVE0190E: File not found: /struts/simple/dojoRequire.js
>>>> 4
>>>>
>>>> Info-I'm using Strust2 and have removed all my other filters (e.g.  
>>>> struts
>>>> 1 and sitemesh) from web.xml - i.e. it's practically empty.
>>>>
>>>> Tapio Holopainen wrote:
>>>>>
>>>>> Hi,
>>>>>
>>>>> I solved this 'response already committed' problem in my application
>>>>> by
>>>>> writing own FilterDispatcher. Here's instructions ->
>>>>> https://issues.apache.org/struts/browse/WW-1526
>>>>>
>>>>> What is still not solved is how to make AJAX work in Websphere 6.1. I
>>>>> have
>>>>> created issue for this ->  
>>>>> https://issues.apache.org/struts/browse/WW-1839
>>>>>
>>>>> Regards,
>>>>>
>>>>> - Tapio
>>>>>
>>>>>
>>>>> On Tue, 27 Mar 2007 00:49:50 +0300, alkira <alex.kira@gmail.com>
>>>>> wrote:
>>>>>
>>>>>>
>>>>>>
>>>>>> I am using Struts2 version 2.0.6, but not using JSF.  This is  
>>>>>> happening
>>>>>> on
>>>>>> the vanilla version of the Showcase application as well, so nothing
>>>>>> specific
>>>>>> to my code.   I tried to upgrade to the latest Websphere fixpack
but
>>>>>> that
>>>>>> didnt help as well.  Let me know if you need any other info.
>>>>>>
>>>>>> Thanks,
>>>>>>
>>>>>> Alex
>>>>>>
>>>>>>
>>>>>>
>>>>>> Martin Gainty wrote:
>>>>>>>
>>>>>>> Hi Alex-
>>>>>>>
>>>>>>> Looks as if you have 2 responses for same Request  
>>>>>>> (GET/POST/PUT/DELETE)
>>>>>>> so
>>>>>>> if Servlet responds with a 200 then Servlet cannot send a second
one
>>>>>>> with
>>>>>>> a 404
>>>>>>> Give us a bit on your environment JSF or Struts2 and which version
>>>>>>> There may be a latency issue here .. tough to say w/o looking
at the
>>>>>>> code
>>>>>>>
>>>>>>> M-
>>>>>>> ---------------------------------------------------------------------------
>>>>>>> This e-mail message (including attachments, if any) is intended
for  
>>>>>>> the
>>>>>>> use of the individual or entity to which it is addressed and
may
>>>>>>> contain
>>>>>>> information that is privileged, proprietary , confidential and
>>>>>>> exempt
>>>>>>> from
>>>>>>> disclosure. If you are not the intended recipient, you are notified
>>>>>>> that
>>>>>>> any dissemination, distribution or copying of this communication
is
>>>>>>> strictly prohibited.
>>>>>>> ---------------------------------------------------------------------------
>>>>>>> Le présent message électronique (y compris les pièces qui
y sont
>>>>>>> annexées,
>>>>>>> le cas échéant) s'adresse au destinataire indiqué et peut
contenir  
>>>>>>> des
>>>>>>> renseignements de caractère privé ou confidentiel. Si vous
n'êtes
>>>>>>> pas
>>>>>>> le
>>>>>>> destinataire de ce document, nous vous signalons qu'il est  
>>>>>>> strictement
>>>>>>> interdit de le diffuser, de le distribuer ou de le reproduire.
>>>>>>> ----- Original Message -----
>>>>>>> From: "alkira" <alex.kira@gmail.com>
>>>>>>> To: <user@struts.apache.org>
>>>>>>> Sent: Monday, March 26, 2007 3:16 PM
>>>>>>> Subject: [S2] Websphere 6.1 Showcase application, Response already
>>>>>>> committed warning in logs
>>>>>>>
>>>>>>>
>>>>>>>>
>>>>>>>> Hi,
>>>>>>>>
>>>>>>>> I am running Struts2 under Websphere 6.1, and getting a lot
of  
>>>>>>>> warning
>>>>>>>> messages in the logs. This is only happening under WebSphere
6.1,  
>>>>>>>> but
>>>>>>>> it
>>>>>>>> works fine under Tomcat.  Also, it's happening both for the
>>>>>>>> Showcase
>>>>>>>> application, as well as my own applications in Struts2.
>>>>>>>>
>>>>>>>> The following is the message (which can occur multiple times
for
>>>>>>>> the
>>>>>>>> same
>>>>>>>> page):
>>>>>>>> [3/25/07 15:39:05:343 EDT] 0000002b SRTServletRes W   WARNING:
 
>>>>>>>> Cannot
>>>>>>>> set
>>>>>>>> status. Response already committed.
>>>>>>>> [3/25/07 15:39:05:343 EDT] 0000002b SRTServletRes W   WARNING:
 
>>>>>>>> Cannot
>>>>>>>> set
>>>>>>>> header. Response already committed.
>>>>>>>>
>>>>>>>> Is anyone else seeing this as well?
>>>>>>>>
>>>>>>>> Thanks!
>>>>>>>>
>>>>>>>> Alex
>>>>>>>> --
>>>>>>>> View this message in context:
>>>>>>>> http://www.nabble.com/-S2--Websphere-6.1-Showcase-application%2C-Response-already-committed-warning-in-logs-tf3468980.html#a9679630
>>>>>>>> Sent from the Struts - User mailing list archive at Nabble.com.
>>>>>>>>
>>>>>>>>
>>>>>>>> ---------------------------------------------------------------------
>>>>>>>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>>>>>>>> For additional commands, e-mail: user-help@struts.apache.org
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Using Opera's revolutionary e-mail client: http://www.opera.com/mail/
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>>>>> For additional commands, e-mail: user-help@struts.apache.org
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>> 
>> 
>> 
>> -- 
>> Using Opera's revolutionary e-mail client: http://www.opera.com/mail/
>> 
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>> For additional commands, e-mail: user-help@struts.apache.org
>> 
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/-S2--Websphere-6.1-Showcase-application%2C-Response-already-committed-warning-in-logs-tf3468980.html#a9804308
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message