struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marco Carnevale" <marco.carnev...@gmail.com>
Subject Re: integrating Tiles in Struts2
Date Tue, 03 Apr 2007 01:56:11 GMT
I had a few issues while working with tiles 2 / struts 2.  Mainly the
problem I found was that the documentation I was reading(
http://struts.apache.org/2.x/docs/tiles-plugin.html ) has incorrect
information.

Correction #1: the taglib uri is NOT  <%@ taglib uri="http://struts
.apache.org/tags-tiles" prefix="tiles" %>

as shown in the example.  It IS <%@ taglib uri="http://tiles
.apache.org/tags-tiles" prefix="tiles" %>.
Correction #2: the tag is NOT <tiles:attribute name="header"/> as shown in
the example.  It is <tiles:insertAttribute name="header"/>

Once I realized these mistakes things became a lot easier.  I think the
errors in the link above are cut/paste errors from the previous version of
tiles.

Hope this helps.




On 3/30/07, Syed Ibrahim <syed.ibrahim@paradyne.co.in> wrote:
>
> Hi,
>
> I have used tiles in Struts 1.3
> But I am not able to integrate Tiles in Struts2.
>
> I found on Apache website that tiles is an experimental feature. So is it
> advisable to use tiles in Struts2?
>
> If yes, please give me the steps to integrate tiles in struts2.
>
> Thanks in advance.
>
> Ibrahim.
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message