struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Newton <newton.d...@yahoo.com>
Subject Re: unable to capture events with <s:tree>
Date Tue, 03 Apr 2007 10:36:26 GMT
--- Manu Mahajan <manu@comprointertech.com> wrote:
> If your code is working then can you please check
> what version of struts you are using because it's
not
> working for me. I am using struts2-core-2.0.6.jar

I'm using 2.0.6, fairly recently upgraded from 2.0.5.

I tried it out again as a sanity check and, of course,
it no longer works (and something *horrible* is
happening on that page that makes Firefox lock up for
like 3 minutes, but I was in the process of changing
it so I must have left something in an awkward
state...)

So yes, I'd say there's a problem, although I'm not
sure when it actually started. Nothing relating to the
tree stuff (appears to have, anyway!) changed between
2.0.5-2.0.6; haven't checked 2.0.4 yet.

I probably won't be able to look at it again until I
resolve my rendering issue, but maybe someone else has
some input.
> Please suggest if I'm on the right track and if this
> could be incorporated in the struts code and what is

> the formal way to suggest this to the developers.

File a JIRA ticket against <s:tree.../>.

It looks as though this may have already been done:

https://issues.apache.org/struts/browse/WW-1813

so you could add a comment and attach your proposed
patches.

(I am curious as to when it broke, now; I would have
sworn it worked under 2.0.5, but now I'm thinking
maybe not since 2.0.4? I dunno.)

d.



 
____________________________________________________________________________________
Don't pick lemons.
See all the new 2007 cars at Yahoo! Autos.
http://autos.yahoo.com/new_cars.html 

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message