struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From alkira <alex.k...@gmail.com>
Subject Re: [S2] struts2-showcase in Websphere 6.1 not picking up static resources
Date Mon, 26 Mar 2007 19:31:01 GMT

Hi Tapio, 

I just noticed your post after I posted mine the same day (so I took my post
out).   I got it working temporarily in my application by bringing in the
static resources that are not found into my project and manually including
the resources, but I am definitely looking forward to the fix.

Thanks, 

Alex



Tapio Holopainen wrote:
> 
> Hi Alex,
> 
> I think that you have same problem like me, take a look at ->  
> https://issues.apache.org/struts/browse/WW-1839
> 
> Regards,
> 
> - Tapio
> 
> 
> 
> -----
> 
> I am trying to get Struts2 running on top of Websphere 6.1 and I am having
> some issues with this.  These issues also occur in the Struts2Showcase. 
> To
> get it running, I am basically deploying the struts2-showcase-2.0.6.war  
> file
> into the Websphere application server.  The application starts up and  
> works,
> however, when I try to run the autocomplete or some of the examples that
> require Dojo, the Dojo part does not work.  When I look into it, some of  
> the
> static resources are not being found, such as CommonFunctions.js and
> dojoRequire.js.  Other ones however are found, like the dojo.js, so not  
> sure
> if it is related to file size.
> 
> I saw a JIRA issue WW-1526 related to this, and even tried to pull the
> patched "FilterDispatcher.java" file into my project, however, it still
> did
> not work.  I also tried the patch with the ServletLauncher contained in
> the
> Wiki and it did not work either.  I even got the latest WebSphere patch
> and
> it is still the same.
> 
> Has anyone run Struts2 Dojo example on Websphere 6.1, or know of a
> solution
> to this?   I would like to avoid manually copying the static content into  
> my
> application if possible.
> 
> Thanks!
> 
> Alex
> 
> -- 
> View this message in context:  
> http://www.nabble.com/-S2--struts2-showcase-in-Websphere-6.1-not-picking-up-static-resources-tf3455643.html#a9640940
> Sent from the Struts - User mailing list archive at Nabble.com.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Websphere-6.1%3A-Ajax-samples-in-struts2-showcase-2.0.6.war-doesn%27t-work-tf3452356.html#a9679925
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message