struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laurie Harper <lau...@holoweb.net>
Subject Re: Struts2: New life to IBM RAD?
Date Wed, 31 Jan 2007 00:13:21 GMT
Correct. Struts2 uses the org.apache.struts2 package whereas Struts1 
uses org.apache.struts, so there is no conflict if both are included in 
a project.

L.

cilquirm wrote:
> From my experience, it is possible to run Struts1 and Struts2 side by side
> As far as I've seen and worked with, other than keeping the "org.apache"
> start of the package name, the namespaces and class names are different.
> 
> 
> 
> Bruno Melloni-2 wrote:
>>
>> Are all the package.class names different between Struts 1.1 and 2.0.x?
>> If they are, then code written to use 2.0.x would have no problems even
>> if RAD forces its old Struts 1.1 JAR files into the project.  (I know
>> that using Ant for the build would help us bypass this issue, but too
>> many of our developers rely on the default IDE build, and changing those
>> habits would be very difficult)
>>
>> Is this wishful thinking?  Or is it time to look for a replacement IDE?
>>
>> Bruno
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>> For additional commands, e-mail: user-help@struts.apache.org
>>
>>
>>
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message