struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laurie Harper <lau...@holoweb.net>
Subject Re: upgrade to 2.0.4
Date Tue, 30 Jan 2007 23:44:36 GMT
Yes, you would certainly need to remove struts2-core-2.0.1 when 
upgrading to 2.0.4, or you'll have multiple versions of the same classes 
in your classpath. The same holds for plugin jars and any/all dependencies.

L.

xiao jie wrote:
> hi:
> I tried to update my application from 2.0.1 to 2.0.4 and I have downloaded all the nightly
built 
> 2.0.4 jar files and plugins i needed and put them under WEB-INF/lib (do I have to remove
the struts2-core-2.0.1 as well), is that all I have to do?
> but I ended up with errors saying 
> Element type "bean" must be declared. 
> File:jar:file:/C:/Documents%20and%20Settings/st.Pamann/project2.0.4/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/webapps/struts2-blank-2.0.1/WEB-INF/lib/struts2-core-2.0.4-SNAPSHOT-20070128.jar!/struts-default.xml
> 
> any suggestions on this will be appreciated!
> thanks
> 
> 
>  
> ____________________________________________________________________________________
> The fish are biting. 
> Get more visitors on your site using Yahoo! Search Marketing.
> http://searchmarketing.yahoo.com/arp/sponsoredsearch_v2.php


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message