struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dariusz Wojtas" <dwoj...@gmail.com>
Subject Re: [S2] Possible issue with remote form submission
Date Sun, 07 Jan 2007 17:01:55 GMT
I removed theme ajax from my form and it still did not work.

Because the current showcase has problems, I copied the remoteforms
sample to my app.
Only 2 of these forms do work with IE (pass params).

I can be sure of this because I have a filter in front of the app
which renders the requested URI with params (works with GET and POST -
works for months).

If this can help, IE shows an error message in the status bar:

  Could not load 'dojo.widget.html.Tooltip'; last tried '__package__.js'

It is something general with the recent S2 from trunk.

Dariusz Wojtas


On 1/7/07, Musachy Barroso <mbarroso@wfscorp.com> wrote:
> Just to make sure that's not it, can you remove the theme="ajax" from
> the form? In the remote button page, on showcase there is an example of
> a button submitting a form, is that working for you?
>
> musachy
>
> Dariusz Wojtas wrote:
> > Hi Musachy,
> >
> > I have a form of this type:
> >
> > <s:form theme="ajax" id=".." action=".." method="POST"  >
> > ...
> > <s:submit theme="ajax" value=".." type="submit" targets=".."
> > cssClass=".." />
> > <s:/form>
> >
> > And this one gets submitted, but IE seems to post it without parameters.
> > At the same time FF posts it with parameters.
> > In both browsers targetting of the submission form works, but IE does
> > not pass params.
> >
> > If this could help, I have a form with some custom tabular structure
> > inside.
> > Also some dojo scripts do not get loaded with current S2 - this could
> > also be the reason ...
> >
> > Best regards
> > Dariusz Wojtas
> >
> >
> > On 1/7/07, Musachy Barroso <mbarroso@wfscorp.com> wrote:
> >> Hi Dariusz
> >>
> >> The remote forms example(and probably the tag) are broken right now. The
> >> easiest way to submit forms asynchronously, that I know is working like
> >>
> >> <s:form ....>
> >>   <s:submit theme="ajax"/>
> >> <s:/form>
> >>
> >> check the ajaxtags doc for examples:
> >>
> >> http://struts.apache.org/2.x/docs/ajax-tags.html
> >>
> >> musachy
> >>
> >> Dariusz Wojtas wrote:
> >> > Using S2 trunk.
> >> > I have noticed that in some cases remote form submission does not pass
> >> > form data to the url.
> >> > This may be reproduced with the showcase:
> >> >   /struts2-showcase/ajax/remoteforms/
> >> > where some of the samples do workand pass parameters, while some
> >> > others do not.
> >> > The same behavious in IE, FF and Opera 9
> >> >
> >> > Has anyone lse noticed this?
> >> >
> >> > Also some of the forms on that page uses 'afterLoading',
> >> > 'beforeLoading' attributes that do not let this page compile by
> >> > default.
> >> >
> >> > Best regards
> >> > Dariusz Wojtas

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message