struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wendy Smoak" <wsm...@gmail.com>
Subject Re: [s2] servlet 2.4 required ?
Date Thu, 07 Dec 2006 14:52:55 GMT
On 12/7/06, nicolas de loof <nicolas.deloof@gmail.com> wrote:

> I'm starting a project based on Java 1.4 and serlet 2.3 (tomcat 4.1). I'd
> like to use Struts2 as it includes retro-translated support for java 1.4.
> According to project main page (
> http://struts.apache.org/2.x/#Platform%20Requirements), servlet 2.4 is
> required.

Yes, Struts 2 requires Servlet 2.4.  The Servlet 2.4 spec was
finalized over three years ago, and if I've got my versions straight,
is part of J2EE 1.4.

> Does this mean I will have to wait all my customer to upgrade to
> JEE5 prior to using Struts2 ? If so, I'll have to wait 1 or 2 years ...

No.  Java EE 5 is Servlet 2.5, not 2.4.  See:

>From http://java.sun.com/javaee/technologies/

Java EE 5
Java Platform, Enterprise Edition 5 (Java EE 5) (JSR 244)
...
Web Application Technologies
Java Servlet 2.5 (JSR 154)
JavaServer Faces 1.2 (JSR 252)
JavaServer Pages 2.1 (JSR 245)
JavaServer Pages Standard Tag Library (JSR 52)

-- 
Wendy

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message