struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tarek Nabil" <Tarek.Na...@dubaiworld.ae>
Subject RE: Parameters not being set on Action in Struts 2
Date Wed, 29 Nov 2006 05:15:39 GMT

Thanks Ted.

I sent the WAR file and zip file containing the source of the action to
your email address directly.

I have a couple of other questions that I'll post on another thread and
I hope you'll help me with them, so that I can conclude my evaluation.

-----Original Message-----
From: Ted Husted [mailto:husted@apache.org] 
Sent: Tuesday, November 28, 2006 4:58 PM
To: Struts Users Mailing List
Subject: Re: Parameters not being set on Action in Struts 2

I inspected it myself in a debugger the other day, and the property
was in the map.

If you like, send me a WAR of the test application, so we can work out
what's wrong. (The list doesn't accept attachments.)

-Ted.

On 11/28/06, Tarek Nabil <Tarek.Nabil@dubaiworld.ae> wrote:
> It exhibits the same behavior even after converting the "param"
> field/parameter to a String.
>
> Is there a way to provide a JUnit test for that?
>
> -----Original Message-----
> From: Ted Husted [mailto:husted@apache.org]
> Sent: Monday, November 27, 2006 6:52 PM
> To: Struts Users Mailing List
> Subject: Re: Parameters not being set on Action in Struts 2
>
> Try it again using a String property, to be sure it is not a problem
> with the type conversion.
>
> On 11/27/06, Tarek Nabil <Tarek.Nabil@dubaiworld.ae> wrote:
> > To clear my doubts, I re-built this application using WW 2.2.4. I
> > expected that it will work perfectly and that would prove it's some
> sort
> > of a bug. To my surprise, it exhibited the exact same behavior!!!!!
> >
> > Now, since it's quite remote that such a drastic bug exists in WW
> 2.2.4,
> > I'm starting to think that maybe the behavior I expect is not the
> > correct one.
> >
> > Now, could someone please clarify whether the following is true?
> > 1- When parameters are available in the "query string", those
> parameters
> > are made available to the action through "
> > ActionContext.getContext().getParameters()". Is this true?
> > 2- If a property on the action has the same name as one of those
> > parameters then the framework will attempt to set the property with
> the
> > parameter's name.
> >
> > This is not what is currently happening. Since WW 2.2.4 is supposed
to
> > be production quality then I'm guessing that there must be something
> > wrong with the configuration. It can not be that some configuration
> I've
> > provided is wrong, simply because I have not provided any. It could
> be,
> > though, that some configuration is missing.
> >
> > The changes I've made to the application to get it to work with WW
> 2.2.4
> > is minimal, so I won't go ahead and copy all the files here.
>
********************************************DISCLAIMER********************************************
This email and any files transmitted with it are confidential and contain privileged or copyright

information. If you are not the intended recipient you must not copy, distribute or use this
email
or the information contained in it for any purpose other than to notify us of the receipt
thereof.
If you have received this message in error, please notify the sender immediately, and delete
this
email from your system.

Please note that e-mails are susceptible to change.The sender shall not be liable for the
improper
or incomplete transmission of the information contained in this communication,nor for any
delay in
its receipt or damage to your system.The sender does not guarantee that this material is free
from
viruses or any other defects although due care has been taken to minimise the risk.
**************************************************************************************************

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message