struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruno Melloni" <Bruno.Mell...@wnco.com>
Subject Using Spring 2.0 - should I use Struts 1.2.9, 1.3.5, or 2.0?
Date Thu, 05 Oct 2006 14:20:14 GMT
I decided to use Spring 2.0 with Struts for my next project.  But I
can't find info on the highest version of Struts that I can use with it.
This is what I found:
 
- Spring 2.0 comes with some parts of Struts 1.2.9, so it would be the
"safe bet".
 
- The latest Struts 1.x is 1.3.5.  It seems to have done significant
repackaging, but I am not clear whether it is "supposed to be" backward
compatible to 1.2.9 or not.
 
- Struts 2.0 is out, but from what I read it is quite different from
1.x, and makes me doubt that it would be compatible with something that
was built for 1.2.9.  I also heard that it still has a few bugs...
normal for a software version ".0".
 
Can someone bring some light into this darkness?
 
---
 
On a separate but related question...  RAD 6 comes with Struts 1.1
(hopelessly outdated).  Can it be upgraded to a more recent Struts
version?  If yes, it is probably documented somewhere, could you point
me to the docs?  Of course, it might be something as simple as including
the desired version of struts in the WEB-INF/lib folder and ignoring the
version that came with RAD 6.
 
Thanks.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message