struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Friedman" <hum...@ix.netcom.com>
Subject RE: RE: [HELP][Struts 2] Problem integrating sitemesh
Date Sun, 03 Sep 2006 03:03:44 GMT
The FAQ has a brief note to do this only
on Tomcat5 but doesn't explain why. 
Always check the FAQ, Wiki, forums, mailing
lists, and search engines for anything that
doesn't work out of the box that you think
should.  Here is the FAQ with that tiny note 
at the bottom:
http://www.opensymphony.com/sitemesh/faq.html

Regards,
David

-----Original Message-----
From: Garner Shawn [mailto:shawndgarner@gmail.com]
Sent: Saturday, September 02, 2006 10:31 PM
To: Struts Users Mailing List
Subject: RE: RE: [HELP][Struts 2] Problem integrating sitemesh

For some reason I had to add the dispatchers to the following:
<filter-mapping>
	    <filter-name>sitemesh</filter-name>
	    <url-pattern>/*</url-pattern>
	    <dispatcher>FORWARD</dispatcher>
    	<dispatcher>REQUEST</dispatcher>
</filter-mapping>

I also had to upgrade from 2.3 xml definition to the following for 2.4

<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"
    version="2.4">

Can somebody explain why this doesn't work without the dispatchers?

Shawn


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message