struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matts" <mateof...@hotmail.com>
Subject Re: [tiles] Re: Struts tiles cewolf problem(Resolved)
Date Mon, 04 Sep 2006 14:45:33 GMT
You thinks well antonio!! It has worked without the <html:base> tag!!!!! 
Thank you very much.
I will try now to integrate it with the real application, and I think I will 
have problems removing <html:base> cause I have other resourses that need 
it!!! But well that is another theme!! thanks

----- Original Message ----- 
From: "Antonio Petrelli" <brenmcguire@tariffenet.it>
To: "Struts Users Mailing List" <user@struts.apache.org>
Sent: Monday, September 04, 2006 11:40 AM
Subject: Re: [tiles] Re: Struts tiles cewolf problem


> Matts ha scritto:
>> Layout1(at web-inf/tiles):
>> <%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>
>>
>> <%@ taglib uri="http://struts.apache.org/tags-tiles"
>> prefix="tiles" %>
>>
>> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
>>
>> <HTML>
>>
>> <HEAD>
>>
>> <TITLE><tiles:getAsString name="title"/></TITLE>
>>
>> <html:base/>
>
> Hehe! I (think I) got it!
> This is the "infamous" <html:base /> tag that, with Tiles, uses your 
> layout JSP page as the base path, I still don't know why. (Just check your 
> produced HTML and look at the <base> tag).
> In these cases I suggest to remove the <html:base/> tag and use only 
> relative paths.
>
> HTH
> Antonio
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message