struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Labey Sébastien <sla...@sopragroup.com>
Subject [Struts2] problem with links and Firefox
Date Thu, 28 Sep 2006 08:05:40 GMT
Hi,
 
I have a strange problem : I have 2 links in my page to change the locale. The "english" and
the "french" link are not build the same way (for tests...) but the 2 solutions give the url
that I want in the end.
 
  <li>
    <ul>
      <%/* anglais */%>
      <a href="<s:url action="acceuil">
                     <s:param name="request_locale">en</s:param>
                   </s:url>">
        <s:text name="layout.english" />
      </a>
    </ul>
      <%/* francais */%>
      <a href="<s:url action="acceuil">
                     <s:param name="request_locale">fr</s:param>
                   </s:url>">
        <s:text name="layout.french" />
      </a>
    </ul>
  </li>
 
But, the strange thing is that on Firefox when I select the link associated with a locale
that is not in the request (ex. select "fr" when my request_locale is now "en"), Firefox opens
a new tab. But when I select the link for the locale that is already in the request (ex. select
"fr" when my request_locale is now "fr") this works fine and the page is still in the same
tab. 
Any idea for this problem? 
Thanks in advance.
 
Sebastien
 
 
Sébastien LABEY
 
Division Immobilier
R&D IKOS
 
04.72.18.47.07
 <mailto:slabey@sopragroup.com> slabey@sopragroup.com
20, chemin du Randin - B1 - 69130 Ecully
P Avant d'imprimer, ayez une pensée pour notre environnement

*

 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message