struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Husted" <hus...@apache.org>
Subject Re: Struts 2 snapshot build work on JDK 1.4.2?
Date Fri, 11 Aug 2006 00:42:04 GMT
On 8/10/06, James Mitchell <jmitchell@apache.org> wrote:
> Looks like I'll have some time this weekend to work on this.  And so
> I wanted to get some feedback on this process.  How do we want to do
> this?
>
> Are both Retrotranslator and Retroweaver necessary for full 1.4
> compatibility?  Or will using just 1 suffice?

AFAIK, RetroTranslator should be sufficient.


> Do we use these from
> the command line or with a Maven plugin or should use antrun maven
> plugin to do it?

I just filtered the JARs from the command line. I suppose the Maven
plugin would work too. I think it might be best to keep this a
separate JAR distribution and make the "cannonical" target Java 5.


>
> In any case, what is the targeted output for all of this?

I uploaded the test distribution from August 2 to my home directory.

* http://people.apache.org/~husted/struts2-core-j4-2.0.0-SNAPSHOT-20060801.zip


>
> http://people.apache.org/builds/struts/nightlies/
>     /2.0.x/struts2-j14-api-2.0.0-SNAPSHOT-20060804.jar
>     /2.0.x/struts2-j15-api-2.0.0-SNAPSHOT-20060804.jar

I'd keep the J4 as a "special" distribution and leave J5 as the
default. So I'd say keep what we got as it is, and just add the ZIP
with a translated J4 JARs.


>
>
> I think for now, I'll add this process manually (as part of my
> nightly bash script) and then we can work out the details later.
>
> --
> James Mitchell
> 678.910.8017

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message