struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig McClanahan" <craig...@apache.org>
Subject Re: [Shale] Validation...
Date Wed, 05 Jul 2006 21:03:51 GMT
On 7/5/06, Rodrigo Barreiros <barreiros.rodrigo@gmail.com> wrote:
>
>
> Hi,
>
> I need use client-side validation in my application. I am using Shale
> Validator (shale-core-1.0.2) with Myfaces 1.1.1. The validation works
> fine,
> but messages appears encoded in wrong way.
> For example, for message (in portuguese):
>
> errors.required={0} ? um campo obrigat?rio.
>
> Appears: "Nome &#233; um campo obrigat&#243;rio." in alert window.
>
> The same happens using corejsf-validator tag.
>
> Any suggests?


One thing to double check is to review how you created your properties
file.  After creating such a file, you need to run the "native2ascii"
command line tool to do the encoding on it.

Another issue might be the character encoding on your JSP page itself.  Be
sure you've set the encoding to UTF-8, using something like either:

    <@page pageEncoding="UTF-8" %>

or

    <@page contentType="text/html;charset=UTF-8" %>


Thanks, Rodrigo


Craig


--
> View this message in context:
> http://www.nabble.com/-Shale--Validation...-tf1896745.html#a5188079
> Sent from the Struts - User forum at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message