struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Gordon <adam.gor...@readytalk.com>
Subject Re: Quick Struts/Validator version question
Date Thu, 29 Jun 2006 16:29:06 GMT
You know, I saw that, but a co-worker told me that it was the version of 
Java that the package was compatible with so I didn't give it a second 
thought...he has been flogged and beaten.  :-)

Any idea of the ramifications of using validator 1.3.0 w/ Struts 1.2.9?

-adam

David Friedman wrote:
> And now for the simple and exact way: check the jar's META-INF/MANIFEST.MF
> file.  I have 1.2.9 and the commons-validator.jar has a META-INF/MANIFEST.MF
> file with this in it:
>
> Manifest-Version: 1.0
> Ant-Version: Apache Ant 1.5.3
> Created-By: Apache Maven
> Built-By: Niall Pemberton
> Package: org.apache.commons.validator
> Build-Jdk: 1.4.2_05
> Extension-Name: commons-validator
> Specification-Title: Commons Validator
> Specification-Vendor: The Apache Software Foundation
> Implementation-Title: org.apache.commons.validator
> Implementation-Vendor: The Apache Software Foundation
> Implementation-Version: 1.1.4
>                         ^^^^^^
> There you go, the validator is version v1.1.4 in struts-1.2.9-bin.zip!
>
> Regards,
> David
>
> -----Original Message-----
> From: Adam Gordon [mailto:Adam.Gordon@readytalk.com]
> Sent: Thursday, June 29, 2006 11:36 AM
> To: Struts Users Mailing List
> Subject: RE: Quick Struts/Validator version question
>
> I think I've answered the first part of my question:  looking in the
> commons-validator.jar file that comes with Struts 1.2.9, the class files are
> dated 12 NOV 2004 and the source package for validator 1.1.4 on the mirrors
> have the same date, so I think I can assume that Struts 1.2.9 comes with
> version 1.1.4 of the validator.  This begs the question as to why there's
> versions 1.2.0 and 1.3.0 of the validator when Struts isn't using it.  Are
> there other uses for the validator framework besides struts?
>
> I'm still looking for an answer to the second half of my question (about any
> ramifications of throwing validator 1.3.0 into Struts 1.2.9) if anyone
> knows.
>
> Thanks,
>
> -Adam
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message