struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan Wynn" <bigwy...@gmail.com>
Subject Re: [shale] shale-test compiled for compatibility?
Date Mon, 22 May 2006 20:54:13 GMT
On 5/22/06, Craig McClanahan <craigmcc@apache.org> wrote:
> On 5/22/06, Ryan Wynn <bigwynnr@gmail.com> wrote:
> >
> > I think this may have been asked before but can someone please make
> > sure that shale-test is being compiled such that it is compatible with
> > jdk 1.4.  I am getting some major-minor version errors when trying to
> > run my unit tests against 1.4.
> >
> > Here is the information from my shale-test manifest:
> >
> > Manifest-Version: 1.0
> > Ant-Version: Apache Ant 1.6.3
> > Created-By: 1.5.0_05-b05 (Sun Microsystems Inc.)
> > Extension-Name: org.apache.shale.test
> > Specification-Vendor: The Apache Software Foundation
> > Specification-Version: 1.0
> > Implementation-Vendor: The Apache Software Foundation
> > Implementation-Version: 20060504
>
>
> Is this from a nightly build?  A snapshot release?  Are you getting a
> "incompatible class format" error, or something different.
>
> The nightly builds and the releases are indeed built with a JDK 1.5 compiler
> (so that the Tiger Extensions module can be compiled) ... but the "source"
> and "target" options for the Test Framework compile are set to "1.4"
> explicty, so it's supposed to work.

The exception is

java.lang.UnsupportedClassVersionError:
org/apache/shale/test/base/AbstractViewControllerTestCase (Unsupported
major.minor version 48.0)

shale-test.jar is from the 20060504 nightly build.

I'll try the latest build and see if that helps.

>
> Thanks,
> > Ryan
> >
>
> Craig
>
>
Mime
View raw message