struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Newton <new...@pingsite.com>
Subject Re: Blank page when trying to forward
Date Fri, 26 May 2006 12:04:00 GMT
Shervin Asgari wrote:
> * @struts.action-forward name="domainwebsiteAdminEdit.page"
> path=".domainwebsiteAdminEdit"
> * @struts.action-forward name="domainAdminEdit" path=".domainAdminEdit"
>
> return viewDomainWebsiteEdit(mapping, form, req, res,
> DOMAINWEBSITE_ADMIN_EDIT_PAGE);
>
> public ActionForward viewDomainWebsiteEdit(ActionMapping mapping,
> ActionForm actionForm,
>            HttpServletRequest request, HttpServletResponse response)
>            throws Exception {
>        ActionForward forward =
> mapping.findForward("domainAdminEdit.page");
>
>        try {
>            RollerSession rollerSession =
> RollerSession.getRollerSession(request);
>
>            request.setAttribute("domainWebsiteModel", new
> DomainWebsiteAdminEditPageModel(
>                    "domainWebsiteAdminEdit.title", request, response,
> mapping, null, null));
>            if (request.getAttribute("domainWebsiteModel") == null) {
>                request.setAttribute("domainWebsiteModel", actionForm);
>            }
>
>        } catch (Exception e) {
>            mLogger.error("Error in DomainWebsiteAdminAction.view()"+ e
> + "\n" + e.getMessage());
>            throw new ServletException(e);
>        }
>    }

Still not working, eh?

I don't actually see you returning a forward here.

Repost the actual code and configuration files.

Dave



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message