struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig McClanahan" <craig...@apache.org>
Subject Re: Building SHALE??? The instructions don't work!
Date Mon, 27 Mar 2006 18:16:12 GMT
On 3/27/06, Hiller, Dean <DHiller@carrieraccess.com> wrote:
>
> I was following the instructions here....
> http://struts.apache.org/struts-shale/building.html
> <http://struts.apache.org/struts-shale/building.html>
>
>
>
> They don't work.  Can someone please update them so they do?  Here is my
> short ant log....


The current build process has a bug in it when the "htmlunit.home' property
does not point at a directory that contains an HtmlUnit release.  You can
avoid this by either

* Downloading HtmlUnit 1.6 from SourceForge, installing it, and
  then pointing this property at the correct directory, or

* Create an empty directory "foo", create a "lib" directory inside
  it, and point "htmlunit.home" at directory "foo".

In the latter case, you won't get the test framework base classes for
HtmlUnit based testing (the compile script has conditionals built in), but
you'll get everything else.

Craig

Buildfile: build.xml
>
>
>
> clean-release:
>
>      [echo] jdk15.present=true
>
>    [delete] Deleting directory
> C:\AAROOT\areas\jakarta\shale-framework-20060327\
>
> dist
>
>
>
> clean:
>
>
>
> execute.14.libraries:
>
>      [echo] Executing clean on module core-library
>
>
>
> clean:
>
>    [delete] Deleting directory
> C:\AAROOT\areas\jakarta\shale-framework-20060327\
>
> core-library\target
>
>    [delete] Deleting directory
> C:\AAROOT\areas\jakarta\shale-framework-20060327\
>
> core-library\dist
>
>      [echo] Executing clean on module clay-plugin
>
>
>
> clean:
>
>      [echo] Executing clean on module test-framework
>
>
>
> BUILD FAILED
>
> C:\AAROOT\areas\jakarta\shale-framework-20060327\build.xml:340: The
> following er
>
> ror occurred while executing this line:
>
> C:\AAROOT\areas\jakarta\shale-framework-20060327\build.xml:941: The
> following er
>
> ror occurred while executing this line:
>
>
> C:\AAROOT\areas\jakarta\shale-framework-20060327\test-framework\build.xml:48
> : C:
>
> \AAROOT\areas\jakarta\shale-framework-20060327\test-framework\${
> htmlunit.hom
> e}\l
>
> ib not found.
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message