struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pham Anh Tuan" <anht...@ichi-corp.jp>
Subject Re: [HELP] Problem when update 1 unicode form
Date Wed, 08 Feb 2006 08:22:10 GMT
again, plz help me!

----- Original Message ----- 
From: "Pham Anh Tuan" <anhtuan@ichi-corp.jp>
To: "Struts Users Mailing List" <user@struts.apache.org>
Sent: Tuesday, February 07, 2006 4:30 PM
Subject: [HELP] Problem when update 1 unicode form


hi all,

I got a problem when I update unicode form :(

so, I have already tested my web application (Struts-ibatis-velocity-tiles) 
on my PC (tomcat 5.5.12, mysql 4.1 - utf8 default, JDK 5.0), everything was 
okie. I could update 1 unicode form (the form which contains unicode 
characters - firstname, lastname). I use 1 filter for output and input, 
below is my web.xml:

 <!-- Filter to set character encoding on each request -->
 <filter>
  <filter-name>Set Character Encoding</filter-name>
  <filter-class>filters.SetCharacterEncodingFilter</filter-class>
  <init-param>
   <param-name>encoding</param-name>
   <param-value>UTF-8</param-value>
  </init-param>
 </filter>

 <!-- Define filter mappings for the defined filters -->
 <filter-mapping>
  <filter-name>Set Character Encoding</filter-name>
  <servlet-name>action</servlet-name>
 </filter-mapping>

 <filter-mapping>
  <filter-name>Set Character Encoding</filter-name>
  <servlet-name>velocity</servlet-name>
 </filter-mapping>

but ... when I deploy and run it on eatj.com, mysql4.1 - utf8, jdk 5.0, I 
couldn't update unicode form, my last name and first name fields couldn't be 
saved with unicode characters (utf-8) ...

what happened :( ... Is this problem of hosting or my web application ??? :(

help me :(

thanks in advance,

bowlkhin 



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message