struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "R. Markham" <markha...@gmx.de>
Subject AW: Debugging Struts Application with Eclipse
Date Thu, 24 Nov 2005 08:12:32 GMT
Hallo Martin,

I found the solution:

Create a batch file with the name setenv.bat. In the Batch file set
set JPDA_ADDRESS=8000
set  JPDA_TRANSPORT=dt_socket

Stores this file in /CATALINA_HOME/bin directory.

Starts tomcat with
Catalina jpda start

So you don't need additional plugins in Eclipse. I find the less Plug Ins
you the more faster is Eclipse.

Regards

Richard


-----Ursprüngliche Nachricht-----
Von: R. Markham [mailto:markham.r@gmx.de] 
Gesendet: Mittwoch, 23. November 2005 15:39
An: 'Struts Users Mailing List'; kindlerm@acm.org
Betreff: AW: Debuging Struts Application with Eclipse


Hallo Martin,

from what I have found it is enough to start the jJVM by

java -Xdebug -Xnoagent
-Xrunjdwp:server=y,transport=dt_shmem,address=8000,suspend=n 
-Djava.endorsed.dir="..\common\endorsed" 
-classpath
"c:programme\java\j2sdk1.4.2_06\lib\tools.jar;..\bin\bootstrap.jar" 
-Dcatalina.base=".." 
-Dcatalina.home=".." 
-Djava.io.tmpdir="..\temp" org.apache.catalina.startup.Bootstrap start

Because this is what is required by sun.

The Problem with all other Plug Ins is that you must develop your struts
application from the beginning with the IDE.

Regards

Richard Markham



-----Ursprüngliche Nachricht-----
Von: Martin Kindler [mailto:kindlerm@arcor.de] 
Gesendet: Mittwoch, 23. November 2005 14:49
An: 'Struts Users Mailing List'
Betreff: AW: Debuging Struts Application with Eclipse

If you are using Tomcat I would suggest you use the Sysdeo Plugin
(www.sysdeo.com). With it one can smoothly debug web apps in Eclipse. I do
it all the time.



Martiin

> -----Ursprüngliche Nachricht-----
> Von: R. Markham [mailto:markham.r@gmx.de] 
> Gesendet: Mittwoch, 23. November 2005 14:40
> An: user@struts.apache.org
> Betreff: Debuging Struts Application with Eclipse
> 
> 
>  
> 
> Hallo 
> 
>  
> 
> Since several days I tried to debug my Struts Application 
> with Eclipse. I set following ENV variables
> 
> Set JPDA_TRANSPORT=dt_shmem
> 
> Set JPDA_ADRESS=8000
> 
> I called Catalina with "jpda start" parameter.
> 
>  
> 
> If I try to connect to jvm in Eclipse I always get the message
> 
> "Failed to connect to remote VM. Connection refused"
> 
>  
> 
> Regards
> 
>  
> 
> Richard Markham
> 
>  
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message