struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aymeric Alibert <aymericn...@gmail.com>
Subject Re: Strange Problem with logic:equals!
Date Fri, 07 Oct 2005 08:55:03 GMT
Do you have the struts-bean tag library defined in your jsp:?
Something like <%@ taglib uri="/WEB-INF/struts-bean.tld" prefix="bean" %>

Aymeric.

On 10/7/05, starki78 <starki78@libero.it> wrote:
>
> Hi, we have a strange Problem
> with logic:equal
>
> Look at the following code:
>
>
> //--> first we create a bean
>
> <bean:define id="myBeanValue" value="1"/>
>
> //--> changing the value is this possible in the way???
>
> <% myBeanValue = "2"; %>
>
>
> // tests with the logic:equals tags
>
> <logic:equal name="myBeanValue" value="1">
> <br>is equal</br>
> </logic:equal>
>
> <logic:notEqual name="myBeanValue" value="1">
> <br>is notequal</br>
> </logic:notEqual>
>
>
> After running the jsp we are getting the result= is equal!!!
>
> But Why?? Is it not possible to redefine the variable
> in the way that we try this in the example!
> What makes us even more worried is that
> when we debug, it neither jumps in the first nor
> in the second logic:equal tag.
>
> Please help me!
>
> Nice Greetings
> Starki
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message