struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dakota Jack <dakota.j...@gmail.com>
Subject Re: Strange Behaviour (ClassNotFoundException)
Date Fri, 18 Feb 2005 15:47:31 GMT
You using Tomcat?


On Fri, 18 Feb 2005 13:36:22 +0000, Ben Taylor <ben.taylor32@gmail.com> wrote:
> Hi,
> 
> I'm im the middle of creating a Struts project using JBuilder, which
> correctly compiles all of my java files to the /classes/ directory
> with the correct nesting for my packages - ie.
> /classes/com/com_name/resource/MyClass.class.
> 
> My problem is that when I run the application it seems to think that
> these files do not exist!  The project builds with no errors yet it
> results in Server 500 errors, which are triggered as a result of not
> being able to find the neccessary files.
> 
> I've looked in the Log4j log file and the paths it says do no exist,
> are exactly what they are meant to be - even copying and pasting the
> result into JBuilder's "Find Classes" option shows the correct file is
> present.
> 
> Having spent literally hours trying to work out what was wrong I
> decided to zip up my souce files and rename the archive 'mysrc.jar',
> which I then added to the /WEB-INF/lib directory.
> 
> Now when I browse through the lib directory I can see all of my files
> (which I've now removed from the /src/ directory).  Although during
> the build compilation they are seemingly present, during runtime the
> web app still cannot find any of the files :o(
> 
> I'm interested if any other web developers have had this kind of
> problem before, or indeed if anyone knows how I can fix it.
> 
> Thank you for any help.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 
> 


-- 
"You can lead a horse to water but you cannot make it float on its back."
"Heaven has changed.  The Sky now goes all the way to our feet.

~Dakota Jack~

"This message may contain confidential and/or privileged information.
If you are not the addressee or authorized to receive this for the
addressee, you must not use, copy, disclose, or take any action based
on this message or any information herein. If you have received this
message in error, please advise the sender immediately by reply e-mail
and delete this message. Thank you for your cooperation."

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message