struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Reumann <strut...@reumann.net>
Subject Re: org.apache.struts.action.MESSAGE not found??
Date Mon, 11 Oct 2004 03:35:15 GMT
Dean Hiller wrote the following on 10/10/2004 11:06 PM:

> I have found out it appears struts is not loading my resource file in time
> for the properties to be read from it or something like that.  Does anyone
> have any ideas?  My struts-config.xml file has this in it....
>   <servlet>
>      <servlet-name>action</servlet-name>
>   <servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
>   <init-param>
>      <param-name>config</param-name>
>   <param-value>/WEB-INF/struts-config.xml</param-value>
>   </init-param>
>   <init-param>
>      <param-name>application</param-name>
>   <param-value>ApplicationResources</param-value>
>   </init-param>
>   <load-on-startup>1</load-on-startup>
>   </servlet>

That's your web.xml. The web.xml part for struts only needs


<servlet-name>action</servlet-name>
   <servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
   <load-on-startup>1</load-on-startup>
</servlet>

Then at the bottom of your struts-config you need your resources definition:

<message-resources parameter="ApplicationResources" null="false"/>


The sample application with Struts shows all of this. Just follow their 
web.xml and struts-config examples.

-- 
Rick

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message