struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Friedman" <hum...@ix.netcom.com>
Subject RE: form validation
Date Wed, 01 Sep 2004 19:14:27 GMT
Albert,

The <action ...> has an "input" parameter which the validate="true" will go
to if any validation fails.  That should be a JSP (/index.jsp), tile
(.some.Tile.Name), or action (/index).

Regards,
David

-----Original Message-----
From: Leung, Albert [mailto:ALeung@Biscom.com]
Sent: Wednesday, September 01, 2004 3:13 PM
To: Struts Users Mailing List
Subject: RE: form validation



>
> For some reason I can't get form validation to work for a particular
> project. If I take the same ValidatorForm, use the same
> validation entry in
> formset, and update the struts-config to use the same form
> bean and action
> it works fine in another project. The project that has
> problems just gives
> me a blank page whenever it finds something wrong. There is
> no stack trace
> or log that can tell me what could be wrong.

If I input values that pass validation it works fine. I think that
eliminates 2) and 3). What do you mean by 1)?

> Could be:
> 1)Missing input param in struts config
> 2)Input goes to page/action that doesn't exist.
> 3)Input goes to action whose forward doesn't exist.


>
>
>
> Please help!
>
>
>
> Albert
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message