struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amleto Di Salle" <disa...@di.univaq.it>
Subject R: JSTL 1.1 EL not working :(
Date Mon, 17 May 2004 13:58:10 GMT
You don't have to declare the .tlds inside the "web.xml"
Try elminate it!

BR
/Amleto


-----Messaggio originale-----
Da: Daniel Perry [mailto:d.perry@netcase.co.uk] 
Inviato: lunedì 17 maggio 2004 15.50
A: Struts User List
Oggetto: JSTL 1.1 EL not working :(


I've tried to use JSTL with my web app, and it's not working!
I downloaded jstl 1.1, and copied jstl.jar, and standard.jar to
WEB-INF/lib. I put the f.tld, fmt.tld, fn.tld in WEB-INF/.

In my web.xml i've got:
  <taglib>
    <taglib-uri>/WEB-INF/c.tld</taglib-uri>
    <taglib-location>/WEB-INF/c.tld</taglib-location>
  </taglib>

  <taglib>
    <taglib-uri>/WEB-INF/fn.tld</taglib-uri>
    <taglib-location>/WEB-INF/fn.tld</taglib-location>
  </taglib>

  <taglib>
    <taglib-uri>/WEB-INF/fmt.tld</taglib-uri>
    <taglib-location>/WEB-INF/fmt.tld</taglib-location>
  </taglib>

If i try and use c:out, it doesnt work!

<%@ page contentType="text/html;charset=UTF-8" language="java" %> <%@
taglib uri="http://java.sun.com/jsp/jstl/core"  prefix="c" %> <c:out
value="${1+1}"/>

gives:
${1+1}

Any idea what's going on?
It looks like the taglib is working fine, but not using el!

Any ideas?

Daniel.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message