struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yee, Richard K,,DMDCWEST" <Ye...@osd.pentagon.mil>
Subject RE: Newbie: Problems After Deploying to Tomcat
Date Tue, 03 Feb 2004 17:03:48 GMT
Colin,
Check out the html:base tag.

-Richard


-----Original Message-----
From: Colin Foulkes [mailto:colin.foulkes@protegra.com] 
Sent: Tuesday, February 03, 2004 8:16 AM
To: Struts Users Mailing List
Subject: RE: Newbie: Problems After Deploying to Tomcat 


Ah... I think I see the problem....

I need to fully qualify my action names (and script paths) with the name of
the application (Prototype1) e.g. <script language="javascript"
src="/Prototype1/WSClient/scripts/XXX.js"></script>

This was apparently being magically handled by the html:form tag in the
login.jsp page. <html:form action="/LoginAction">

Is there a tag I could use to accomplish this same magic in my src
attribute?

Also, assuming this is the same problem in my filter, is there some
recognized way for handling the forward in the filter.

Thanks
again

Colin





-----Original Message-----
From: Colin Foulkes 
Sent: February 3, 2004 9:47 AM
To: Struts Users Mailing List
Subject: Newbie: Problems After Deploying to Tomcat 


Hi,

I'm fairly new to the struts but have been able to get a small struts app
working fine under the internal Tomcat(4.0.6) in Netbeans. Everything here
works fine.

When I try to run the app under a standalone Tomcat (4.1.29) I get two
problems with my application.

1. I have created an authentication filter that forwards requests to my
LoginAction if the user isn't logged in. When running in the external
Tomcat, this forward fails, with a status 404  The requested resource
(/LoginAction.do) is not available.


2. When I remove the filter from the web.xml mappings, the application can
find the LoginAction fine (through my Login.jsp) and I'm happily insise the
app. The Second problem I have is that the first page I go to after the
LoginAction (/WEB-INF/jsp/mainmenu.jsp) contains javascript include
references <script language="javascript"
src="/WSClient/scripts/XXX.js"></script>
These javascript files are not being loaded into my page.

Does anyone have any ideas why these problems are occurring, and have any
solutions.

Thanks in advance

Colin


---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message