struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Milbratz <Bmilbr...@participate.com>
Subject RedirectingActionForward oddness with IE6?
Date Sat, 22 Nov 2003 20:43:53 GMT
Hi,

I'm seeing some oddities w/ the behavior of Internet Explorer 6 (IE6) with
regards to the struts RedirectingActionForward. I don't see the same problem
in Mozilla (Firebird) or Netscape 7.1. I'm querying to see if anyone has
come across this issue or know a workaround...any ideas:

The problem:
When on an 'edit' page when the user hits 'apply' the struts action should
persist the users changes, rebuild the URL and redirect to the current
location. 

What's happening: 
It works fine when the user hits apply once or twice, but usually on the
third time the struts action doesn't see the parameters in the request. To
clarify,  the url looks like this:
  http://localhost:8080/pe/action/adm/foo/edit?ID=10103702
but the request object doesn't have any parameters. Thus the page is blanked
out (i.e. as if they were creating a new item). Hitting refresh correctly
loads the values..

I've verified that all my code is working exactly as I expect it. I suspect
that the issue lies in the browser.

these browsers work:
  firebird 0.6.1
  netscape Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

this one doesn't:
  IE 6.0.2800.1106

thanks,

bill milbratz











            newPath = GenDisplayClientHelper.buildApplyUrl(newPath,
origAction, id, returnUrl, forwardUrl);            
            nextAction = new RedirectingActionForward(newPath);

Mime
View raw message