struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kris Schneider <k...@dotech.com>
Subject Re: Servlets 2.4
Date Tue, 04 Nov 2003 12:48:11 GMT
My reading of the 2.4 spec is that HTTP/1.1 support is *required*, not that it's
the only version supported. Hang on, here's the quote from section SRV.1.2 What
is a Servlet Container?

The required versions of the HTTP specification that a container must implement
are HTTP/1.0 and HTTP/1.1.

Quoting Christian Bollmeyer <java@christianbollmeyer.de>:

> Hi,
> 
> just read the following article from OTN:
> 
> http://otn.oracle.com/oramag/oracle/03-nov/o63dev_jsp.html
> 
> which basically gives an overview on the new features of
> JSP 2.0/Servlets 2.4. I stumbled over this passage:
> 
> "This release supports only HTTP 1.1, so Servlet 2.4
> applications won't be able to serve HTTP 1.0 clients."
> 
> Now, what's that supposed to mean - no backward
> compatibility? Can somebody possibly shed some
> more light on this?
> 
> -- Chris.

-- 
Kris Schneider <mailto:kris@dotech.com>
D.O.Tech       <http://www.dotech.com/>

---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message