struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Frank <s.fr...@vierundsechzig.de>
Subject Re: Invalid Class file Format (help same problem)
Date Tue, 16 Sep 2003 11:14:54 GMT
I guess, Oracle comes with its own runtime-enviroment (a fellow stated 
in the other mail, that oracle 9iAs runs on jdk1.3). The jsp-examples 
work, as they ship pre-compiled. Going back to 1.3 should not be such a 
big problem, as struts runs fine on 1.3 - Maybe there is an oracle-guy 
somewhere, that can enlighten us, if and how you can teach oracle to run 
with 1.4...

Richard Raquepo wrote:

> running oc4j.jar with the parameter -version only gives this:
> 
> Oracle9iAS (9.0.3.0.0) Containers for J2EE (build 020927.1699)
> 
> actually i can't also run the jsp included in the Oracle 9iAS like the
> examples
> found on tomcat. but the servlets example are working just fine. seem's that
> Oracle 9iAS can't compile the jsp files. how come?
> 
> do i have to lower the java version i am using right now?
> 
> anymore suggestions?
> 
> thanks.
> 
> -Richard
> 
> ----- Original Message -----
> From: "Stefan Frank" <s.frank@vierundsechzig.de>
> To: "Richard Raquepo" <rraquepo@primeorion.com>
> Cc: "Struts Users Mailing List" <struts-user@jakarta.apache.org>
> Sent: Tuesday, September 16, 2003 6:31 PM
> Subject: Re: Invalid Class file Format (help same problem)
> 
> 
> 
>>hmm, just guessing: Maybe Oracle 9iAS runs on its own, older jvm? What
>>does java.version/java.vendor say, when you start it from the server?
>>Before replacing the tools.ja, were you able to compile a plain jsp
>>without any struts-tags in it? (this does not look like a struts
>>problem, as he complains about a wrong Version of Object)
>>
>>Richard Raquepo wrote:
>>
>>
>>>i only have JDK 1.4.2  installed on my PC
>>>anyway here's the value of environment variables
>>>PATH = c:\utils;C:\j2sdk1.4.2\bin;c:\mysql4\bin;C:\jakarta-ant\bin
>>> JAVA_HOME=C:\j2sdk1.4.2\
>>> CLASSPATH=.;C:\j2sdk1.4.2\lib\tools.jar;%JAVALIB%
>>>
> 
> JAVALIB=C:\crm-dev\others.lib\pp-tools.jar;c:\javalib2\ms\msbase.jar;c:\java
> 
>>>lib2\ms\mssqlserver.jar;c:\javalib2\ms\msutil.jar;C:\datamapper\source\;
>>>
>>>anymore suggestion?
>>>
>>>thanks,
>>>Richard
>>>
>>>
>>>----- Original Message -----
>>>From: "Stefan Frank" <s.frank@vierundsechzig.de>
>>>To: "Richard Raquepo" <rraquepo@primeorion.com>
>>>Cc: "Struts Users Mailing List" <struts-user@jakarta.apache.org>;
> 
> "Christian
> 
>>>Bollmeyer" <java@christianbollmeyer.de>
>>>Sent: Tuesday, September 16, 2003 5:05 PM
>>>Subject: Re: Invalid Class file Format (help same problem)
>>>
>>>
>>>
>>>
>>>>Hi Richard,
>>>>
>>>>it looks like your also using an older compiler. Do you have some older
>>>>jdk's (<1.3) on your machine?! Last time I installed Oracle, they used
a
>>>>jdk1.1 and set it into the path (and they also used to run java-stored
>>>>procedures in the database). Can you check you enviroment for:
>>>>
>>>>PATH
>>>>JAVA_HOME
>>>>CLASSPATH
>>>>
>>>>maybe one of them contains an older jdk?! If orion forks for compiling
>>>>the jsp's (as bea does), you may fall back to these
>>>>enviroment-variables, ignoring the j22home you started the server with.
>>>>
>>>>cheers
>>>>stf
>>>>
>>>>
>>>>
>>>>Richard Raquepo wrote:
>>>>
>>>>
>>>>>hello,
>>>>>
>>>>>I get the same error. Although i have copied the tools.jar from the jdk
>>>>>installation to both j2ee/home and j2ee/home/lib
>>>>>
>>>>>followed what others have done but im still not able to hack my
>>>
>>>application
>>>
>>>
>>>>>to run. :p
>>>>>
>>>>>can someone help me get my struts application work on Oracle 9iAS
>>>>>(9.0.3.0.0)
>>>>>
>>>>>Im using Win2K SP3, JDK 1.4.2, Oracle 9iAS, latest sruts1.1 stable
>>>
>>>release.
>>>
>>>
>>>>>thanks in advance.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>>>>>here's ny error details <<<<<<
>>>>>
>>>>>500 Internal Server Error
>>>>>OracleJSP: oracle.jsp.provider.JspCompileException:
>>>>>
>>>>>Errors
>>>>>
>>>
>>>
> compiling:C:\oc4j_extended\j2ee\home\application-deployments\default\default
> 
>>>>>WebApp\persistence\_pages\\_login.java
>>>>>
>>>>>error: Invalid class file format in C:\Program
>>>>>Files\Java\j2re1.4.2\lib\rt.jar(java/lang/Object.class).  The
>>>
>>>major.minor
>>>
>>>
>>>>>version '48.0' is too recent for this tool to understand.
>>>>>
>>>
>>>
> C:\oc4j_extended\j2ee\home\application-deployments\default\defaultWebApp\per
> 
>>>>>sistence\_pages\_login.java:0: Class java.lang.Object not found in
> 
> class
> 
>>>>>com.orionserver.http.OrionHttpJspPage.
>>>>>
>>>>>^
>>>>>2 errors
>>>>>
>>>>>many thanks,
>>>>>
>>>>>   Richard
>>>>>
>>>>
>>>>
>>>>---------------------------------------------------------------------
>>>>To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
>>>>For additional commands, e-mail: struts-user-help@jakarta.apache.org
>>>>
>>>>
>>>
>>>
>>>
>>>
>>>---------------------------------------------------------------------
>>>To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
>>>For additional commands, e-mail: struts-user-help@jakarta.apache.org
>>>
>>>
>>
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
>>For additional commands, e-mail: struts-user-help@jakarta.apache.org
>>
>>
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: struts-user-help@jakarta.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message