struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mohd Amin Mohd Din" <am...@nc.com.my>
Subject Validator not configured properly?
Date Wed, 17 Sep 2003 13:03:00 GMT
Hi,
 
What else do I need to check? The form is working perfectly at the
moment but it is not being validated
In struts-config.xml
<snip>
    <form-bean name="Financial.Sponsor.ReceiveSponsorshipForm"
               type="org.apache.struts.validator.DynaValidatorForm">
</snip>
<snip>
    <action path="/financial/sponsor/receiveSponsorshipSetup"
 
type="com.enc.edu.icms.fin.sponsor.view.ReceiveSponsorshipSetupAction"
            name="Financial.Sponsor.ReceiveSponsorshipForm"
 
input="/WEB-INF/jsp/icms/financial/sponsor/receiveSponsorship.jsp"
            parameter="action"
            validate="true">
</snip>
<snip>
  <plug-in className="org.apache.struts.validator.ValidatorPlugIn" >
    <set-property property="pathnames"
value="/WEB-INF/validator-rules.xml,
                                             /WEB-INF/validation.xml" />
  </plug-in>
</snip>
 
In validation.xml
<snip>
      <form name="Financial.Sponsor.ReceiveSponsorshipForm" >
      <field property="semesterId" depends="required">
        <msg name="required" key="icms.error.field.null"/>
        <arg0 key="icms.financial.semester"/>
      </field>
</snip>
 
validator-rules.xml is present and contains the normal stuff
 
Help
Amin
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message