struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Hill" <andrew.david.h...@gridnode.com>
Subject RE: Managing Multiple Struts-Config.xml --> Not Working --- > Urgent
Date Wed, 16 Apr 2003 03:57:14 GMT
Not sure how to go about fixing this one as Ive not tried multiple config
files myself. :-(
Ill forward this message to the list. Should be someone there that can help.
regards
Andrew

-----Original Message-----
From: venkatramani.p@polaris.co.in [mailto:venkatramani.p@polaris.co.in]
Sent: Wednesday, 16 April 2003 11:34
To: craigmcc@apache.or
Cc: struts-user@jakarts.apache.org; korny@sietsma.com;
andrew.david.hill@gridnode.com
Subject: REG: Managing Multiple Struts-Config.xml --> Not Working --- >
Urgent


Hi

I'm using Struts1.1b version with weblogic 6.1 as my App server.  I came to
know that i can use as many as struts-config.xml for my application. I
tried using the following :

     <!-- Managing Multiple Struts-config -->

           <init-param>
               <param-name>config</param-name>
               <param-value>/WEB-INF/struts-config</param-value>
           </init-param>

           <init-param>
               <param-name>config/test</param-name>
               <param-value>/WEB-INF/struts-config-test.xml</param-value>
           </init-param>

When i used the above I got the following exception :

javax.servlet.jsp.JspException: Cannot retrieve mapping for action
/Sample/delete
         at org.apache.struts.taglib.html.FormTag.lookup(FormTag.java:784)
         at
org.apache.struts.taglib.html.FormTag.doStartTag(FormTag.java:481)
         at jsp_servlet._sample.__view._jspService(__view.java:179)
         at weblogic.servlet.jsp.JspBase.service(JspBase.java:27)
         at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java
:265)

         at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java
:304)

         at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java
:200)

         at
weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletCo
ntext.java:2456)

         at
weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java
:2039)

         at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:139)
         at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)

I understand the error. The mapping which i did in struts-config-test.xml
is not able to retireve it.

I tried using the following also :

           <init-param>
               <param-name>config</param-name>

<param-value>/WEB-INF/struts-config-test.xml,/WEB-INF/struts-config-test.xml
</param-value>
           </init-param>

When i'm using the above config as soon as the Weblogic6.1 server starts it
is giving error.

Pls help me in this regard as it is very urgent.

Thanks in advance.

Venkat
Polaris Software Lab,
Chennai.
INDIA




---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message