struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Sullivan" <michael.sulli...@hewitt.com>
Subject Error using Struts-Faces in WSAD 5
Date Fri, 21 Mar 2003 21:55:08 GMT
Trying to build my own example app in WSAD 5.0 (using the README.txt found 
in the jakarta-struts-faces-0.3), I am getting the following error trying 
to go to my first faces jsp.

[3/21/03 14:10:02:073 CST] 329f2016 WebGroup      E SRVE0026E: [Servlet 
Error]-[JSP 1.2 Processor]: javax.faces.FacesException: Renderer Not Found 
For Renderer Type:StrutsHtml
        at 
com.sun.faces.renderkit.html_basic.HtmlBasicRenderKit.getRenderer(HtmlBasicRenderKit.java:377)
        at 
javax.faces.component.UIComponentBase.encodeBegin(UIComponentBase.java:919)
        at javax.faces.webapp.FacesTag.encodeBegin(FacesTag.java:343)
        at javax.faces.webapp.FacesTag.doStartTag(FacesTag.java:225)
        at 
org.apache.struts.faces.taglib.HtmlTag.doStartTag(HtmlTag.java:125)
        at org.apache.jsp._logon._jspService(logon.jsp  :2)
        at 
com.ibm.ws.webcontainer.jsp.runtime.HttpJspBase.service(HttpJspBase.java:89)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
        at 
com.ibm.ws.webcontainer.jsp.servlet.JspServlet$JspServletWrapper.service(JspServlet.java:344)
        at 
com.ibm.ws.webcontainer.jsp.servlet.JspServlet.serviceJspFile(JspServlet.java:598)
      ...


I've added the servlet and servlet mapping to my web.xml

        <servlet>
                <servlet-name>faces</servlet-name>
                <display-name>FacesServlet</display-name>
                <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
                <load-on-startup>1</load-on-startup>
        </servlet>

        <servlet-mapping>
                <servlet-name>faces</servlet-name>
                <url-pattern>/faces/*</url-pattern>
        </servlet-mapping>

and the action in my struts-config.xml (which is launched from my 
index.jsp) is

        <action path="/enterSite" type="teststrutsfacesapp.actions.EnterSiteAction" name="enterSiteForm"
scope="request">
                <forward name="logon" path="/faces/logon.jsp">
                </forward>
        </action>

I've included the struts-faces.jar, jsf-api.jar,jsf-ri.jar, jstl-el.jar, 
and standard .jar in the WEB-INF/lib directory.  I've also put the 
struts-faces.tld into the WEB-INF directory.

When I run the same war on Tomcat (4.0.6) I'm getting a different error:

java.lang.IllegalArgumentException: Cannot find module configuration
                 at 
org.apache.struts.faces.component.FormComponent.lookupModuleConfig(FormComponent.java:317)
                 at 
org.apache.struts.faces.renderer.FormRenderer.encodeBegin(FormRenderer.java:164)
                 at 
javax.faces.component.UIComponentBase.encodeBegin(UIComponentBase.java:920)
                 at 
javax.faces.component.UIForm.encodeBegin(UIForm.java:88)
                 at 
javax.faces.webapp.FacesTag.encodeBegin(FacesTag.java:343)
                 at 
javax.faces.webapp.FacesTag.doStartTag(FacesTag.java:225)
                 at 
org.apache.jsp.logon$jsp._jspService(logon$jsp.java:323)
                 at 
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:107)
          ...

Any help would be appreciated!
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message