struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adolfo Miguelez" <pell...@hotmail.com>
Subject Which J2EE version is compliant with Struts apps?
Date Thu, 06 Mar 2003 10:07:32 GMT
Hi All,

an easy question. AFAIK, Struts is based on servlets 2.2 and JSP 1.1 specs. 
Therefore a J2EE 1.2 compliant app server is needed. Right?

We are investigating about using WAS5 and WSAD5. Both of them actually 
permit to choose among developing or deploying J2EE1.2 or J2EE1.3 compliant 
applications.

The question is:

could we deploy Struts apps as J2EE 1.3 compliant apps and therefore 
standing on Servlets 2.3 and JSP 1.2 specs. I guess that should be backwards 
compatibility in new specs so should be no problem, but I would appreciate 
confirmation. Any expected compatibility mismatch?

What J2EE specs Struts deployers match for your Struts apps? What are the 
choices? (I suppose no difference among Struts 1.0.2 and Struts 1.1, since 
both are servlets 2.2 and JSP 1.1 compliants).

Thanks in advance,

Adolfo.






_________________________________________________________________
MSN 8 helps eliminate e-mail viruses. Get 2 months FREE*. 
http://join.msn.com/?page=features/virus


---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message