struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ashokd" <ash...@visualsoft-tech.com>
Subject PrePopulation Problem - Urgent
Date Thu, 21 Mar 2002 05:11:21 GMT
Hi,

I have a .jsp page, In this page if the user clicks a Hyper link one Action
class will invoke.
In this action class I am setting some values to the Form Bean and
redirecting to the same page.
These values are not prepopulating in jsp page.

When the user navigates to another page and then comes to the first page
then these values are populating.

This problem is coming with Specific IE versions only.

After putting cache invalidate tag this problem overcome in some versions.
<%
 response.setHeader("Cache-Control","no-cache");
 response.setHeader("Pragma","no-cache");
%>


But still it is their in one Version of  I.E 5.0

I taken the form bean values into strings and printing down in jsp page.

These values are coming good but not prepopulating.

Even though I tried directly assiging these string values to <html:text
...... value="<%=var1 %>".

Even though no result.

If the user refreshes the pages then these values are populating.

If any one faced same type of problem pls let me know the solution or causes
to this problem.

Thanks In Advance,
Ashok.D


---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message