struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim T. Young" <Young_Ti...@cat.com>
Subject xml validation error on Tiles plugin entry
Date Tue, 14 Jan 2003 18:40:38 GMT

I am using WSAD 5 and am having a problem enabling the Tiles plugin in the
struts-config.xml file.

I put this entry into the file:

<plug-in className="org.apache.struts.tiles.TilesPlugin">
      <set-property property="definitions-config" value=
"/WEB-INF/tiles-defs.xml" />
      <set-property property="definitions-parser-validate" value="true" />
      <set-property property="moduleAware" value="true" />
</plug-in>

and I get validation errors on the first 2 set-property lines

<set-property property="definitions-config" value="/WEB-INF/tiles-defs.xml"
/>
<set-property property="definitions-parser-validate" value="true" />

The error messages are:
"Invalid data for attribute "property" in part definitions-config type
set-property"
and
"Invalid data for attribute "property" in part definitions-parser-validate
type set-property"

Oddly enough when I take the - (dash) out of the property="" the validation
errors go away.

The DTD I am pointing at is:

<!DOCTYPE struts-config PUBLIC "-//Apache Software Foundation//DTD Struts
Configuration 1.1//EN"
 "http://jakarta.apache.org/struts/dtds/struts-config_1_1.dtd">

Any help would be appreciated!

Thanks
Tim



--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message